1

Let me get straight, I have Intel WiFi hotspot on my computer, I can broadcast and use the wireless internet at the same time, It works fine and I tested with my cell phone. There are few issues when i connect with RASPBERRY PI

1) when I broadcast my wifi (without sharing my internet) then my raspberry pi gets the IP address and rest is proper-NO ISSUE, (IP-192.168.1.5 something like ..)

2) but when I try to share my Internet (Intel wifi pro network software) and then broadcast my wifi then my raspberry pi is not getting the IP address, on my computer it shows connected and when I scan the IP its not listed. I don't know whats happening. Android phone works correctly but Raspberry PI is not requesting for IP i suppose(IP - 192.168.137.240 something like this ..)

My settings :

1) --- $ sudo nano /etc/network/interfaces

    auto lo
    iface lo inet loopback
    iface eth0 inet dhcp

    allow-hotplug wlan0
    iface wlan0 inet dhcp
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
    iface default inet dhcp

2) ---- $sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1

    network={
            ssid="Intel-CP-HARSHA-VAIO"
            scan_ssid=0
            psk="BONJOUR"

            # Protocol type can be: RSN (for WP2) and WPA (for WPA1)
            proto=WPA

            # Key management type can be: WPA-PSK or WPA-EAP (Pre-Shared or Enterprise)
            key_mgmt=WPA-PSK

            # Pairwise can be CCMP or TKIP (for WPA2 or WPA1)
            pairwise=TKIP
            group=TKIP

            #Authorization option should be OPEN for both WPA1/WPA2 (in less commonly         used are SHARED and LEAP)
            auth_alg=OPEN
    }

    network={
            ssid="Wifi-OTHER"
            key_mgmt=NONE
            auth_alg=OPEN
    }

and second, how do i make this wifi in continuous scan mode, mean every time of I restart my wifi hotspot the raspberry pi should automatically connect, I did all this before I re installed the OS and now its all screwed up ... I dont remember how I did, And i am certainly sure there was no background task and all I guess.

0

the settings are completely fine, When i added the proxy settings then it works fine .. i believe the DHCP request for IP goes for the first time only when its required until then the IP is not allocated to the device, like the device will be in zombie state or something .. There is still one problem let ... what shall i do for my raspberry to auto connect when i reboot my WiFi router ????

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.