1

I have tried to install the one from apt, but that was really old

So I tried to go to mongo website and download the newest version

but then I get this isse:

The following packages have unmet dependencies:
 mongodb-org-server:arm64 : Depends: libc6:arm64 (>= 2.18) but it is not installable
                            Depends: libcurl3:arm64 (>= 7.16.2) but it is not installable
                            Depends: libgcc1:arm64 (>= 1:4.2) but it is not installable
                            Depends: libssl1.0.0:arm64 (>= 1.0.1) but it is not installable
E: Unable to correct problems, you have held broken packages.

why is this not installable? any suggestion?

  • Latest MongoDB is 64-bit only. Plain RaspiOS is 32-bit. The 64-bit Raspbian is still in beta testing. You will need to switch to a supported 64-bit operating system. – Dougie Jun 26 at 15:20
  • arm64? Is that the correct architecture for Raspberry Pi OS? – joan Jun 26 at 15:24
3

You are using Raspbian. This is only built with a 32 bit architecture armhf. I seems you have downloaded MongoDB with the 64 bit architecture arm64. You cannot run 64 bit programs on a 32 bit architecture. You either have to use a 32 bit MongoDB or use a 64 bit operating system. There is a 64 bit Raspberry Pi OS in beta test. You can try to use that.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.