1

I finally got my Pi to display on an old TV, via the RCA connector. Unfortunately, the Pi outputs a picture that is bigger than the TV can display. It does this on both the TV pictured here: enter image description here

and a newer (though still pretty old) flatscreen we have, so it probably isn't the TV.

All the fixes I find for this problem I can find are specific to HDMI overscan, and none of them have fixed this. I just can't seem to find someone who has had this same problem with the RCA connection.

2

I have two old TVs that I got to work using the composite connection. Both were fixed by adjusting the overscan settings. On the older, smaller TV, setting overscan_left, overscan_right, overscan_top and overscan_bottom along with adjusting framebuffer_width and framebuffer_height did the trick. I have the NOOBS SD card and used Linux running in VirtualBox on a Windows 7 box to edit the config.txt file. For the second TV, setting the four overscan values and framebuffer sizes did not make any difference. Eventually I found a reference to overscan_scale=1 and tried that and everything started working. I was able to change these values in two ways in RASPBMC, one using ssh to login to a running system and edit /boot/config.txt and the other was to add them in the System Configuration page under "PROGRAMS". Using ssh was much easier if you have access that way.

  • Where is reference to overscan_scale=1 ? I have searched without success. – Milliways Apr 26 '14 at 2:32
  • I first saw a mention of it in an 16-JUL-2013 entry in the raspberrypi forums [raspberrypi.org/forums/viewtopic.php?f=78&t=50100 ]("Emulation Station - Some ongoing frustrations"). Google brings up several other references to it for me. – scm0 May 18 '14 at 21:59
1

Look at http://elinux.org/R-Pi_ConfigurationFile which describes the settings in /boot/config.txt. I believe these should work for composite video (but I haven't used this).

The overscan can be set using sudo raspi-config Advanced Options.

You can also configure with /opt/vc/bin/tvservice

/opt/vc/bin/tvservice -s will display current settings

/opt/vc/bin/tvservice -c "PAL 4:3" will set the aspect ratio (which I think defaults to 5:4).

  • Good advice, but didn't fix this specific problem. Thanks for the info, though. – b4ux1t3 Apr 19 '14 at 5:21
0

As it turns out, there are two places in the config.txt that have overscan options if you use NOOBS to install. So, if you are having a similar problem, make sure you scroll to the bottom of the file and are certain that overscan is set properly there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.