7
pi@raspberrypi:/$ sudo apt-get update
Hit http://archive.raspberrypi.org wheezy InRelease
Hit http://mirrordirector.raspbian.org wheezy InRelease
Hit http://archive.raspberrypi.org wheezy/main armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/main armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/contrib armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/non-free armhf Packages
Hit http://mirrordirector.raspbian.org wheezy/rpi armhf Packages
Ign http://archive.raspberrypi.org wheezy/main Translation-en_US
Ign http://archive.raspberrypi.org wheezy/main Translation-en
Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en_US
Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en
Ign http://mirrordirector.raspbian.org wheezy/main Translation-en_US
Ign http://mirrordirector.raspbian.org wheezy/main Translation-en
Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en_US
Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en
Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en_US
Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en
Reading package lists... Error!
E: Problem parsing dependency Depends
E: Error occurred while processing libwww-mechanize-perl (NewVersion2)
E: Problem with MergeList /var/lib/apt/lists/mirrordirector.raspbian.org_raspbian_dists_wheezy_main_binary-armhf_Packages
E: The package lists or status file could not be parsed or opened.
pi@raspberrypi:/$ 

I deleted the file mentioned

sudo rm /var/lib/apt/lists/mirrordirector.raspbian.org_raspbian_dists_wheezy_main_binary-armhf_Packages

And reran the update, but it failed again after the download.

7

According to this blog post, and this askubuntu question you need to enter the following at the command line:

sudo rm /var/lib/apt/lists/* -vf

and then run

sudo apt-get update
  • This worked (getting rid of all the files instead of just the one with the error), there must be some file interdependency which doesn't show up in the error message. – Cade Roux Sep 21 '12 at 14:58
  • @CadeRoux if you look at the 2 links I included it seems to have something to do with old files in the cache and is a known bug in Ubuntu at least - probably with apt. – Steve Robillard Sep 21 '12 at 17:40
0

Hmm, this might be unrelated as it appears you solved your problem, however I found this page when I googled a similiar error:

E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/dpkg/status
E: The package lists or status file could not be parsed or opened.

I had ignored the unzip error write error (disk full?) when I unzipped raspbian jessie to an sd card. The .img file was truncated to 4gb due to the size limitations of the fat32 filesystem. I went back and unzipped the image to an ext3 filesystem instead (ntfs would also work for >4Gb files), dd'd it and could then apt-get update.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.