0

I'm trying to mount a NFS share on my NAS and hitting a few troubles. I can mount the NAS myself via the mount command but I can't get my /etc/fstab right. Some help would be appreciated!

So my first attempt of:

sudo mount 192.168.25.100:/share/MD0_DATA/Qmultimedia /mnt/multimedia/

Ended up with:

mount.nfs: rpc.statd is not running but is required for remote locking.
mount.nfs: Either use '-o nolock' to keep locks local, or start statd.
mount.nfs: an incorrect mount option was specified

OK, not too sure what's best so I've gone with...

sudo mount -o nolock 192.168.25.100:/share/MD0_DATA/Qmultimedia/mnt/multimedia/

And that maps my files as expected. So I then I umount that share & try via /etc/fstab by adding the following line:

192.168.25.100:/share/MD0_DATA/Qmultimedia /mnt/multimedia auto defaults,nolock 0 0

Save, try mount -a and I'm presented with:

mount: special device 192.168.25.100:/share/MD0_DATA/Qmultimedia does not exist

Now it clearly does exist. I'm just getting some options wrong I guess. I've tried specifying the filesystem type (ext4) instead of auto but still no dice.

Any help would be greatly appreciated!

1

You're using the auto mount option. You need to be specify that it is nfs so that it knows the first part is actually a server and not some other sort of thing.

Here's an example fstab line from my pi:

miro:/mnt/files3/videos    /home/pi/Videos3    nfs     intr,nolock    0 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.