4

I just got my Pi 2 and started experimenting on it.

I'm running Raspbian and I installed xrdp for remote desktop. I created a new user "prograde", and logged via rdp, and it works fine. The problem is, that I don't get the bar at the top, and no menu button. It's just a clean desktop and a waste basket.

If I log in with the pi account, the top bar and the menu button are there.

Where do I find the settings to show or not show them ?

3

A common problem for this is that the .xsession file is missing from the new user's home directory. Try copying that file from the pi user's home directory to that of the new user.

Edit:

As prograde mentioned in the comments, it appears some versions have moved the file to .config/.lxsession

  • I found no .xseesion in the home directory, but there was a .config/.lxsession directory that i copied, and when I logged in again, I had a menu bar. So thanks! =) – prograde Dec 20 '15 at 1:15
  • @prograde: sounds like a setting file changed between versions... Glad it helped! :) – Jacobm001 Dec 20 '15 at 5:42
  • The next time I logged in, the menu panel had dissappeared... Is there a spec for the config somewhere, so that I can edit the settings for the desktop? – prograde Dec 26 '15 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.