1

I have RPi 2 with NOOBS Jessie (1.5.0). I've connected it to my laptop (Win7) through ethernet cable and done internet sharing from WiFi. Internet on raspberry is working, ssh also working (I cannot just ping using name "raspberrypi", but with IP it's working), everything is fine. Bridge connection doesn't work.

Now I want to make visible RPi in my local network. For example I want to connect by ssh from another computer in the same network. I have no idea what can I do to achieve this. I know that much easier is to connect pi directly to the router, but it is not always possible, at least for me.

2

When using Windows ICS (Internet Connection Sharing), your clients computers are using NAT (Network Address Translation) on a ICS's private LAN. Indeed the only visible address on your networks will be your PC's IP Address.
For SSH, you need to Port Forward port 22 on your firewall. This tutorial will help you on the setup. you can use '22' inbound and outbound, Windows is not very familiar with SSH :)

2

Thanks @Fcm.

Your answer gave me a clue for a new research and I've found solution.

  1. Connect RPi to computer by ethernet cable
  2. In "Network Connection" choose your wireless adapter and open "Properties"
  3. Go to tab "Sharing" and check "Allow other network users to connect..."
  4. As "Home networking connection" choose "Local Area Network"
  5. Click "Settings..."
  6. Click "Add..."
  7. In "Description of service" write whatever you want - name of it
  8. In "Name or IP address" write IP address of your RPi
  9. For internal and external "Port number" write 22
  10. To connect to RPi use IP of your laptop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.