3

I am trying to install Chromium 48 on my Raspberry Pi 2 Model B. I have already gotten all of the necessary files downloaded and expanded using these commands:

mkdir Chromium
cd Chromium/
wget https://commondatastorage.googleapis.com/chromium-browser-snapshots/Arm/103408/chrome-linux.zip
unzip chrome-linux.zip

After that finished running I used this command:

./chrome-linux/chrome

But I got this error:

./chrome-linux/chrome: symbol lookup error: /opt/vc/lib/libEGL.so: undefined symbol: glPointSizePointerOES

I have been trying to resolve the issue myself but I am new to Raspberry Pi so any help would be greatly appreciated.

I should also mention I already had a version of Chromium installed so I had all the other packages and libraries.

Thanks in advance.

  • Are you following a tutorial? If so which one? – Steve Robillard Jan 20 '16 at 6:50
  • It looks as though you are missing a library so ldd ./chrome-linux/chrome may help you to identify what is missing... – SlySven Jan 20 '16 at 9:37
  • I have used multiple sources to get to where I am. I got Chromium in the first place from (conoroneill.net/…). Its definately unzipped. I tried "ldd ./chrome-linux/chrome" and it returned "not a dynamic executable" – CapitanCodice Jan 20 '16 at 20:06
1

Seems to me like you are using outdated instructions. Chromium is now in the apt-get repositories. All you need to do is this:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install chromium-browser

If you're asked "Do you want to continue?" or something like that, hit "y" then Enter and your Pi will download and install Chromium and its requirements.

0

It might be that you're using an unsupported version of that library.

Here are some points:

  • You may have to recompile.
    • Chromium requires at least version 2.15 of the libc6 library. This can be found on Raspbian Jessie. Compiling on Wheezy would be problematic.
    • I think you also have to link libGLESv2.so and maybe libOpenVG.so. Mess around with the Makefile if you're recompiling.
  • Do not use any mesa-based graphics library!
  • Maybe consider Iceweasel?
0

Running the following commands should work if you are on the newest version of Raspbian, which is Raspbian Jessie.

wget https://dl.dropboxusercontent.com/u/87113035/chromium-browser-l10n_48.0.2564.82-0ubuntu0.15.04.1.1193_all.deb
wget https://dl.dropboxusercontent.com/u/87113035/chromium-browser_48.0.2564.82-0ubuntu0.15.04.1.1193_armhf.deb
wget https://dl.dropboxusercontent.com/u/87113035/chromium-codecs-ffmpeg-extra_48.0.2564.82-0ubuntu0.15.04.1.1193_armhf.deb
sudo dpkg -i chromium-codecs-ffmpeg-extra_48.0.2564.82-0ubuntu0.15.04.1.1193_armhf.deb
sudo dpkg -i chromium-browser-l10n_48.0.2564.82-0ubuntu0.15.04.1.1193_all.deb chromium-browser_48.0.2564.82-0ubuntu0.15.04.1.1193_armhf.deb

This worked for me with no problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.