1

I'm in the USA and have a raspberry pi 2 and 4 usb adapters. 1 of which was sold with the raspberry pi 2, another that I bought based on online reviews saying that it worked (plug-n-go) with linux and the Raspberry Pi, and also 2 other devices. All of them locate the available wifi-hotspots and show their signal strengths, but none of them will actually connect, even though I've put in the password properly. Raspbian doesn't deliver any failure message, any success message, or any report of any type after I key in my password into popup that asks for it. The only think that happens after I type in my password and hit okay is that the popup disappears. No internet connection.

So, I don't think this is an issue with a USB WiFi adapter. It seems to be something going on with Raspbian (Debian Jessie) ... or perhaps a rare hardware failure on my RPi2. Is there a configuration file I should edit? Should I try another operating system or rebuilding from scratch Raspberry Pi 2? I'm at a complete lose as to what the problem is. I've used both a desktop and a laptop with Linux (Kubuntu and Ubuntu) to connect to this password enabled wifi spot, but the Raspberry Pi 2 fails. I'm looking for any suggestions that you think might be helpful.

PS- I've already tried the diagnostics from BASH, running lsusb and lsmod and looking at their hardware, and following the standard troubleshooting to get the usb WiFi adapters to work. They are finding the signal strengths of all the WiFi hotspots, but none of them can actually connect. So, I have yet to use this RPi2 with wifi.


wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="dlink"
    key_mgmt=NONE
    wep_key0="myPasswordHere"
}

network={
    ssid="xfinitywifi"
    key_mgmt=NONE
}

network={
    ssid="HPE710n.802B4F"
    key_mgmt=NONE
}

interfaces

# Please note that this file is written to be used with dhcpcd.
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'.

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

auto wlan1
allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Additional information

The connection is through a Dlink Wireless Router using standard WEP security. There is no captive portal. Windows, Ubuntu and Kubuntu have all been using it successfully.


New Troubleshooting Information just added

I downloaded and then installed Ubuntu-Mate-15.10.1 onto the Raspberry Pi 2. Both HDMI sound (and wifi adapter) worked perfectly and effortlessly immediately after installation.

I also downloaded and installed the very latest version of Raspbian [ 2016-02-09 ] Both HDMI sound ( and wifi adapter ) continued to fail, as before.

So, this is definitely Not a Hardware problem with my Raspberry Pi 2. It's certainly an issue with Raspbian, the operating system. Since everyone from Britain and Australia seem to have no problem with HDMI sound (or wifi adapters) using Raspbian, I wonder if this could be a regional incompatibility issue or some sort of hardware blockage by region?

  • Can you add the contents of your /etc/wpa_supplicant/wpa_supplicant.conf and /etc/network/interfaces? – Patrick Cook Feb 21 '16 at 2:13
  • @Patrick Cook Yes, I've got them added to the post now. I'm trying to connect to he ssid named "dlink"; the ones without passwords also didn't work. My real password is all alpha and numeral characters, beginning with a "0" [zero]. I edited it out for privacy – user12711 Feb 21 '16 at 5:22
1

Edit your network interfaces file in this way and reboot your Pi. Before editing this file you should take a backup for revert back this file, if any problem encountered.

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet manual
allow-hotplug wlan0

auto wlan0


iface wlan0 inet dhcp
    wpa-ssid "Wi-Fi username"
    wpa-psk "Wi-Fi password"

There is a problem this configuration that it do not allows you to search for a network and connect. If you know the ssid and password you can connect to network without any problem.

0

Are you trying to connect to captive portals like MacDonald's or Starbucks? If so, MAC cloning my phone's MAC so I could log in with my phone first worked for me.

See:https://en.wikipedia.org/wiki/Captive_portal

Clarification: In the US some free hot-spots will not let the Rpi connect to the internet because of a captive portal. See the link above for a definition and a way to connect using a phone and a MAC clone. I am not spamming for MacDonalds or Starbucks. Those are the two main hot-spots in the US.

  • The connection is through a Dlink Wireless Router using standard WEP security. There is no captive portal. Windows, Ubuntu and Kubuntu have all been using it successfully. I'll edit this information into my question. – user12711 Feb 27 '16 at 14:52
  • no, I'm not trying to connect to captive portals like McDonalds or Starbucks. It's my home's IUP through a namebrand router. – user12711 Aug 25 '16 at 18:10
0

I found a solution for me! I bashed my head against a wall for a couple days. I followed all tutorials and still no luck. I installed wicd-curses (which I always use) and it didn't work straight out of the box. Then I poked around a bit in the preferences. I went to the External Programs tab and changed the DHCP from Automatic to dhclient and it worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.