1

After deciding to use zsh, I started using the GUI again, as it supports Powerline fonts for the oh my zsh theme. Anyways, I used sudo raspi-config and set the boot option to GUI with required login. After restarting, I noticed a small box in the top right of the screen. Clicking on it brought up a menu with three desktop environments: Default XSession, LXDE, and Openbox, with Default XSession selected. I decided to try LXDE, and after logging in I was greeted with LXDE. I went back to the login screen and selected Openbox. Logging in presented me with a grey screen and a mouse. After a few minutes of waiting, I decided to reboot, so I went to a TTY and typed reboot.

I switched the DE back to Default XSession and tried to log in. It just went back to the login. So I changed Boot to GUI autologin, and tried again. It just went to the login. I tried rebooting to CLI and typing startx, but it stopped and said that it shut down the X server.

If it helps, I'm using Raspbian.

0

There are not really enough details in your question to find the source of the failing graphical login, but usually something important for the X session doesn't start up properly and hence the session setup fails and you're back at the login screen.

To debug such issues further, have a look at the end of the log file /home/pi/.xsession-errors. Maybe you want to add your findings to the posting retro-actively so you can get better fitting and less generic answers.

One guess though: Did you make zsh the default /bin/sh, too? Because that's not supported by zsh since its sh compatibility mode is not good enough for such a purpose.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.