3

Hey! There's a solution under the question, go look...

I'm using the Adafruit USB to TTL connector purchased from Microcenter. I have two separate parts, and have tried them both.

I've wired it 6/Black, 8/White, 10/Green on the GPIO pins. I burned Raspbian to my SD card, and booted it. What few characters render properly, it looks like it's booting right. However, everything I get on the console is garbage.

Garbage on Serial Port

I've verified the baud rate both in my term software and in the Windows Device Manager for COM256 (you might also notice I tried goosing the com port to something else).

I'm totally befuddled, I don't know what's going on, just that the serial port seems to almost, but not quite, work. Sometimes I get a couple of sane characters in and out, but never more than a few before it's all garbage again.

I've tried lowering the baud on the port to 9600 to see if that helps, but all I get is slower garbage on the port. I tried using power from the 5v pin on the USB serial term cable as well, in case it was something wrong with the grounding, maybe make sure they're using the same power? Still garbage.

I'm at my wits end!

The Solution:

There's two problems here. One, the RasPi 3 now uses the serial UART port for Bluetooth, meaning the port is going to receive gibberish. Second, my personal terminal program wasn't reading the content correctly, and needed to be set to English.

The second one is easy to figure out if it impacts you, so I'm going to put the solution to the first problem (Bluetooth going a-viking all over the serial port) here so no dead links!

  1. Mount your Raspberry Pi boot card on your computer so you can make edits to the files inside.
  2. Edit boot.txt in the root directory.
  3. Add these lines to the bottom. The first one turns off bluetooth, the second one activates the miniuart on the ports we're supposed to be looking for serial connections on:

    dtoverlay=pi3-disable-bt
    dtoverlay=pi3-miniuart-bt
    
  4. Load that back into your Pi and boot it up. Point your terminal to the USB device, and it should now work!
  • Disconnect pin 10 (RxD) and see what happens. – Milliways Mar 31 '16 at 5:55
  • The letters in "GNU" are all even parity and no parity bit. Hint? – PaulF8080 Mar 31 '16 at 7:36
4

Acording to this question, to use UART on the Pi-3 you will need to disable bluetooth.

  • 1
    Great link! I searched for at least an hour, found a lot of answers, but not that one. And, more importantly, not one that ACTUALLY CONTAINED THE ANSWER IN STACK OVERFLOW, but always links, links, links elsewhere. – Zoey Boles Apr 1 '16 at 2:57
2

Assuming the baud rate is correct, and the connection is good. I suspect that the language setting is incorrect. From the setup menu select general and change the language from English to UTF8.

  • I wish I could flag both of you as the answer, because it was a combination of BOTH required to get it to work. I picked Patrick's answer only because his answer actually made the port work; yours made it stop printing garbage once it was working – Zoey Boles Apr 1 '16 at 2:59
  • No problem just glad we could help. – Steve Robillard Apr 1 '16 at 3:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.