0

I'm very new to using a raspberry pi. Recently I purchased one (a raspberry pi 3) and I was playing around with it. All of the sudden when I turn it on, it takes me to LXDE login screen instead of the usual Raspbian desktop. Why is this happening? How can I make it go back to the raspbian desktop on default.

This was not happening before. It began happening when I attempted to modify the autostart file.

1

it takes me to LXDE login screen

Technically that's the lightdm login screen, LDM, where "DM" is short for display manager. You are not wrong in the sense that it is sort of in use by LXDE and I think maintained by the same people as part of there project, but wrong in the sense that it does not by necessity log you into LXDE. That depends on how it is configured.

Also I wanted to make sure you understand "the raspbian deskop" is LXDE. The login screen is a display manager optionally used to, well, log in.

How can I make it go back to the raspbian desktop on default.

Use raspi-config to re-enable "GUI autologin".

If that does not work perhaps because:

It began happening when I attempted to modify the autostart file.

Then you should try restoring the autostart file to what it was before. Presuming you did not save a copy, you will need to look into an original image to get one.

  • This did not work it still takes me to white log in screen – unconditionalcoder May 28 '16 at 14:25
  • It would seem raspi-config is broken on your system for some reason then. I can't speculate about that. If you were using an old image, it might be because it is out-of-step with the underlying mechanism -- raspi-config is just a shell script that calls simple commands for you, but if those don't work for it then they won't work for you. You may have to reinstall since since if no one else proposes a way to diagnose that issue.... – goldilocks May 28 '16 at 14:37
  • See also my edit at the end about your edit to the question. – goldilocks May 28 '16 at 14:39
  • Try re-installing the raspberrypi-ui-mods package with this command: sudo apt reinstall -y raspberrypi-ui-mods. – Botspot Sep 4 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.