1

I have a brand new Pi 3 Model V v1.2, using raspbian, with both USB and Ethernet completely dead - keyboard and network don't work. The same keyboard and network work on an older Pi 1 next to it.

On boot it shows a few lines of "Raspberry Pi dwc otg handle mode mismatch intr 68 mode mismatch interrupt currently in device mode". Could this be the same problem described on https://www.raspberrypi.org/forums/viewtopic.php?f=98&t=87123 ? How would I "ground the OTG pin" on a Pi 3 (and is this a good idea) ?

Or is this hopeless, clear hardware fault - buy another one? I just got this one! ;-)

FYI It initially gave the "rainbow box" on boot (not the little rainbow in the upper right hand corner), so I bought a new power. Even with this strong power, it works once and on reboot still gives the "rainbow box" on re-boot - too hot? Bad SD card which works once and then on reboot is too hot?! From what I understand, this is technically a separate problem from my main problem described above, because when it does boot, then there is a blinking cursor, and apart from no working kbd and nw I think it's fine & happy.

PS: I've run rpi-update and apt-get update/ upgrade on the micro SD card inserted into an older Pi 1, to have latest software on the card.

  • If it is a power issue I think they could be related; note the ethernet and USB use the same controller. The big rainbow on boot though isn't power though, it just means it did not boot beyond a certain point and is stuck there (that screen always appears briefly, I think). A dud or missing SD card might do that. If you have a spare card I would try burning the most recent Raspbian onto it and see what happens. – goldilocks Jul 1 '16 at 17:44
  • Did you download the new OS for Pi3? The old OS's wont work on the new Pi3. – bluepinto Jul 1 '16 at 19:51
  • I DL from here raspberrypi.org/downloads/raspbian, that should work for the Pi3, right – vorburger Jul 1 '16 at 23:13
  • FTR I've tried this with another SD card and still same error. So I much suspect that this board has a hardware fault, and will try to get another one. – vorburger Jul 4 '16 at 10:26
1

FTR: This message ("Raspberry Pi dwc otg handle mode mismatch intr 68 mode mismatch interrupt currently in device mode") appears to indicate a (brand new!) RPi 3 broken at the hardware level... I just got another new one, and with the SAME SD card(s) and USB keyboard and Ethernet network cable the new one works great.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.