1

I have not been able to find an answer to this anywhere, so I'm posting it here.

Issue: connecting a RPi with the latest Jessie update via Ethernet and using a Windows 10 machine to access the internet via Internet Connection Sharing on another network device (eg WiFi).

3
  • OK Im quite new and in other Stack Exchange areas I didnt have enough rep to answer my own questions, noted for the future, thanks.
    – Scalextrix
    Mar 10, 2017 at 17:24
  • 1
    OK reframed as a Q&A
    – Scalextrix
    Mar 10, 2017 at 17:33
  • Welcome to Raspberry Pi! Please take the tour and visit the helpcenter to see how things work here. Thank you for your contribution, however, please note that meta-tags like "answer" or "solved" should not be put in the question title. Accept a working answer instead.
    – Ghanima
    Mar 10, 2017 at 18:17

1 Answer 1

2

There is a problem in that Windows 10 will always revert to the following IP address and Subnet Mask whenever ICS is enabled:

192.168.137.1
255.255.255.0

The RPi will not auto-detect this and sets itself with something like:

169.154.72.93
255.255.0.0

Changing the IP & Subnet on the windows machine will not work, because using ICS will over-ride the settings. So a static IP must be set in the RPi, its important to note this should be done in /etc/dhcpcd.conf add the following:

interface eth0
static ip_address=192.168.137.2
static routers=192.168.137.1
static domain_name_servers=192.168.137.1 8.8.8.8

setting the static DNS is critical, and adding the Windows 10 host, then the address of a real DNS server.

This then allows you to directly plug the RPi into Ethernet and have internet available via Windows ICS.

2
  • While I don't doubt that your solution worked, if you set ICS as DHCP server to allocate addresses it should work. I don't have Windows 10, but this works on earlier versions.
    – Milliways
    Mar 10, 2017 at 22:54
  • I did a search for your solution, I cant find how its done, can you point me to something?
    – Scalextrix
    Mar 11, 2017 at 12:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.