Raspberry Pi V2-Jessie crashed. I cannot reformat SD card???

My Raspberry Pi V2 running Jessie crashed yesterday. As I watched the boot up afterwards it was full of errors relating to the boot SD, etc. I assume that the SD card had been corrupted. I tried the "Restore" option for booting and that gave me errors also.

Next using HDDRawCopy v1.1, tried restoring a backup image to that SD card. Same problem, will not boot and lots of I/O errors. I tried to format this card hoping that that would correct the failing areas. Using SDFormatter 4 I got an error message that the SD card was locked, thus formatting was impossible. The write protect tab is set properly.

I tried using Windows 10 to format with a similar "I can't do it" results. I tried a different SD card, also a Raspberry Pi NOOBs image, which gave the same results.

Now I found another 8GB SD card and tried to restore my backup to that card, again using HDDRawCopy 1.1. This time HDDRawCopy says that the backup image and the SC card are slightly different in size (the SD being a bit larger) and throws a write error and shuts down (it also does that when I tried using a 32 GB SD card.). In the past I'm sure I have restored 8GB images to 16GB SD cards?

Every formatting method I've tried (Nikon camera, Panasonic camera, Windows 10 Device Manager, Windows 10 "properties:format", Windows 10 DISKPART, ...) seems to think the card is lock or not available to formatting. Rebooting the PC did not help.

If the PC will read the card, I assume it is compatible with SHSD cards?

This morning I downloaded and installed the latest version of SD Formatter (version 5). Using the second 8GB SD card above, the new version formatted the card - voila!!! Then I tried to copy the latest download of the Raspberry Pi NOOBs files and the copy failed: Disk write protected :-(

I tried to reformat it again with SD Formatter 5 and that program now throws an error that the SD disk was write protected.

So now I have two 8 GB micro SD cards which are out of action. I'm afraid to try with another one, 16 or 32 GB as I can not afford losing additional card to this problem.

I started up an old Windows 7 laptop which also would not format the cards.

I would appreciate any ideas or solutions....RDK

  • Hi, can you please specify what type of reader you are using? If it is SDHC card, there is a lock slider on it. You might have switched that slider. Please check this once. This always creates the same issue that you are facing. Apr 8, 2020 at 20:30
  • This is an old issue, but to answer your questions, I was using a sd to standard memory card adapter and the tab was not in the read-only position. The card was bad.
    – RDK
    Apr 9, 2020 at 7:37

2 Answers 2


Having tried the SD card format program I would be 100% sure the card was dead but as a last gasp you could try using Diskpart in Windows:

  • Run diskpart.exe and in its command window
  • list disk
  • Find the number of the SD Card - double and triple check this is the correct disk (do not blame me if you get it wrong)
  • select disk x where x is the number of the SD card
  • clean

If you still get a read only message it time to order a new SD card.

As for getting the data back onto a card, I know the Mac version of Etcher from Balena copes with the issue where the new card is a little smaller than the original AS LONG as you have not filled the card.


I feel you. I hated messing around with those crappy sdhc. After having to reformat and reinstall raspbian several times due to their hardware failure, I switched to having the root filesystem on an USB pendrive for all my "mission critical" raspberry pi applications. I have stuff running since YEARS like this, 24/7, and I lost just a couple of USB pendrives, until I now find what I think it's really reliable (never had a single failure with this particular brand/size. Now they are no more in production, so I have a little stockpile of them).

In the end, you will have a small sdcard booting the Pi and the main system on the USB stick from where it will run, preserving the sdcard from all the write operations that will destroy them.

Recently, on the RPi3 (please check this info) should be available a method even easier to move the root filesystem to the USB stick.

Anyway, for details on how to implement this, have a look at:


I used an older guide, but basically it's the same.

Good luck!

  • 1
    Interesting and worth looking into, BUT it is not an answer to my question. Maybe I should have asked how one really determines if an SD card is bad?...
    – RDK
    Aug 12, 2017 at 5:01
  • Probably (and also probably you might have asked it on another stack exchange). But you didn't. Your problem is Raspberry Pi related, and you said "I would appreciate any ideas or solutions"
    – dentex
    Aug 12, 2017 at 6:19
  • Sure go ahead and downvote the only answer.
    – dentex
    Aug 23, 2017 at 20:08
  • It wasn't me that down voted. It appears that I do not have enough seniority to vote, up or down
    – RDK
    Aug 24, 2017 at 4:46
  • No problem I know that.
    – dentex
    Aug 24, 2017 at 5:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.