0

I am to my wit's end. My problem is I cannot ssh into my Pi with my ubuntu laptop through its virtual USB ethernet interface it creates. I made the necessary modifications to the config.txt and commandline.txt files to load the modules for the USB Ethernet interface. It shows up on my laptop as..

enp0s20u2

and I do have any avahi packages installed. I got them through...

sudo apt install avahi-*

And if I do...

avahi-discover

the dialog shows up and my Raspberry pi shows up under its interface and under IPv6 with raspberrypi.local. Except it has no IPv4 address under 169.254.0.0/16. I can ssh into it with this command...

ssh -6 pi@fe80::ae36:c6d9:1710:f6d2%enp0s20u2

But in my view the whole point of avahi and zeroconf is to do all the associating automagically and I would be able to just use the hostname.local Is my zeroconf not working or am I missing something?

0

I have figured it out! For anyone with my issue, for some reason the ubuntu pc isn't figuring out it isn't gonna get an ipv4 ip. So go into the adapter settings and turn off IPv6 addressing and set IPv4 addressing to Link-Local Only and suddenly it will connect once you disable the connection and re-enable it and now you have an IPv4 address of 169.254.x.x and you can connect using the hostname.local

  • You don't med to disable IPv6, but cam set it in Network Manager to Link-local only for your network interface that the Pi represents. This avoids that the Network Manager disables the usb0 interface because it things that IPv6 connectivity is broken. And this disabling happens only after 30 to 60s, so it looks then as if mDNS/avahi has stopped working. – TheDiveO Aug 19 '17 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.