I have a little problem with trying to force audio via an HDMI TV/Monitor, heres what I can get the Pi to do.

Without forcing HDMI Mode using hdmi_drive=2 the monitor works fine with the correct resolution (1360x768). With and without setting


The only problem is there is no audio via HDMI (Audio jack works when configured).

When I then go to force audio using hdmi_drive=2 it then allows audio to be played BUT the resolution then mucks up. Using /opt/vc/bin/tvservice -s still shows that it is in the 1360x768 mode but text still goes outside of the screen.

Any help?

Config.txt located @ http://paste.ubuntu.com/5654451/

Thanks - Ryan Walmsley

2 Answers 2


Most TVs have various scanning modes, which is part of the reason overscan is necessary. If you can find an option called "format" or "scanning mode" or anything like that, select the "PC" or "Just scan" mode. In this mode, the TV will display its input pixel for pixel. It seems that not all TVs have this mode, sadly, and there's no way around it, but most should.

  • No such option on my TV. Seems like cheap TVs are not that goood (I always had an audio problem with my PC on it. May 11, 2013 at 20:25
  • That's too bad. Seems like you're stuck with overscan, then. Also, I realize that I didn't really address your audio problem at all, so sorry about that. I don't know much in that respect, but I think that if you run alsamixer or some other of the alsa-utils, you might be able to spot if the pi is sounding on the HDMI or not. I can't say for sure, though.
    – krs013
    May 12, 2013 at 2:35

Sorry, question solved already.

Seems to be the TV, tried my other (Semi identical tv, Same specs different software) and it works.

I half fixed it by overscanning each side by 48 pixels but can still see a big difference in clarity,


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.