My USB numeric keypad works in NOOBS but not in Rasbpian. It's a Dicota Abacus Hub.

I'm not sure where to start trying to fix this. I could change OS if that would be easier - my basic needs are to run Chromium and have this keypad working.

Here's what /var/log/syslog says when I plug it in... looks OK to me but still nothing happens when I press keys.

Jul 11 14:08:46 raspberrypi kernel: [  107.852621] usb 1-1.3: new high-speed USB device number 8 using dwc_otg
Jul 11 14:08:46 raspberrypi kernel: [  107.954506] usb 1-1.3: New USB device found, idVendor=05e3, idProduct=0608
Jul 11 14:08:46 raspberrypi kernel: [  107.954540] usb 1-1.3: New USB device strings: Mfr=0, Product=1, SerialNumber=0
Jul 11 14:08:46 raspberrypi kernel: [  107.954555] usb 1-1.3: Product: USB2.0 Hub
Jul 11 14:08:46 raspberrypi kernel: [  107.958280] hub 1-1.3:1.0: USB hub found
Jul 11 14:08:46 raspberrypi kernel: [  107.958767] hub 1-1.3:1.0: 4 ports detected
Jul 11 14:08:47 raspberrypi kernel: [  108.232852] usb 1-1.3.1: new full-speed USB device number 9 using dwc_otg
Jul 11 14:08:47 raspberrypi kernel: [  108.336036] usb 1-1.3.1: New USB device found, idVendor=05a4, idProduct=8001
Jul 11 14:08:47 raspberrypi kernel: [  108.336069] usb 1-1.3.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Jul 11 14:08:47 raspberrypi kernel: [  108.336087] usb 1-1.3.1: Product: USB Keypad     
Jul 11 14:08:47 raspberrypi kernel: [  108.336100] usb 1-1.3.1: Manufacturer: Keypad
Jul 11 14:08:47 raspberrypi kernel: [  108.349590] input: Keypad USB Keypad      as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/1-1.3.1/1-1.3.1:1.0/input/input5
Jul 11 14:08:47 raspberrypi kernel: [  108.354514] hid-generic 0003:05A4:8001.0006: input,hidraw0: USB HID v1.10 Keyboard [Keypad USB Keypad     ] on usb-bcm2708_usb-1.3.1/input0
Jul 11 14:08:47 raspberrypi kernel: [  108.370773] input: Keypad USB Keypad      as /devices/platform/bcm2708_usb/usb1/1-1/1-1.3/1-1.3.1/1-1.3.1:1.1/input/input6
Jul 11 14:08:47 raspberrypi kernel: [  108.393215] hid-generic 0003:05A4:8001.0007: input,hidraw1: USB HID v1.10 Mouse [Keypad USB Keypad     ] on usb-bcm2708_usb-1.3.1/input1

Additional info: the keypad has a built-in usb hub. If I plug a regular keyboard into the hub, then that keyboard will work ok.

Edit: The keypad also seems to disconnect and reconnect all the time when I'm typing on it. I tried it through a powered USB hub and it does the same, but I also tried it on my PC and it works fine.

  • Just wondering, do you have any settings for overclocking on? If so, what are they?
    – syb0rg
    Aug 6, 2013 at 3:53
  • Silly question but does the keypad work after turning number lock off and on? I know that on my computer and laptop the number lock button has to be turned off and on to get it to work sometimes. Are you also testing inside LXDE or terminal and do you have an linux machine that you can test it on. Aug 6, 2013 at 7:37
  • I've tried both with and without overclocking
    – Greg
    Aug 7, 2013 at 14:46
  • The numlock key toggles the light on and off ok, but the keyboard doesn't do anything otherwise in either mode (in Raspbian). It works OK in NOOBS so it's not a hardware problem or even compatibility with the Pi itself.
    – Greg
    Aug 7, 2013 at 14:48

4 Answers 4


Presumably NOOBS runs a linux kernel just like all of the options it appears to present, so this is a little strange and understandably frustrating. Note that although even some of the people responsible have taken to referring to various linux distributions as if they were separate OS's, this is a misnomer: they are all packaged variations on the same operating system (linux). With regard to hardware compatibility, what works on one linux distribution should (or could be made to) work on another, and what can't work on one can't work on another either.

So on the positive side obviously your keypad can work, but for some reason on raspbian it doesn't. That's a little bizarre because USB keyboards are standardized -- unless you have a very unusual keypad (you don't actually say what it is). NOOBS does not look very user friendly to me WRT to accessing the system log, but in raspbian it's /var/log/syslog -- you could have a look at what appears in there when you plug and unplug the keypad.


You may want to check http://elinux.org/RPi_VerifiedPeripherals to see if your keyboard is compatible with the Pi

  • 2
    It's not on the list but it does work in NOOBS so it must be compatible to some degree
    – Greg
    Aug 7, 2013 at 10:45

Try pressing the NumLock key on the keypad. Some distros disable it on boot. The easiest way to enable NumLock on boot is to install numlockx:

sudo apt-get install numlockx

And then add numlockx the init script*:

sudo sed -i 's|^exit 0.*$|# Numlock enable\n[ -x /usr/bin/numlockx ] \&\& numlockx on\n\nexit 0|' /etc/rc.local

* Taken from this answer.


I had the exact same issue, was using a Mac keyboard with a built in usb-hub.

I ended up trying with another keyboard, despite the Mac one working fine in NOOBS, and it worked immediately as advertised.

It's not much of an explanation, but I figured it worth pointing out that despite the keyboard being fine under NOOBS, it can apparently be worthwhile trying with a different keyboard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.