0

I followed the instructions given here to install Xenomai on a Raspberry Pi 3.

After installing the kernel (now the RPi uses the kernel-xenomai.img during boot) I couldn't access my network, neither through WiFi nor Ethernet. Furthermore, I cannot use UART or SSH to access the RPi.

I tried using raspi-config to configure the Network credentials and enable UART and SSH again (I had done it before installing Xenomai), but I still cannot use UART and the RPi is not connected to my network.

I assumed that after installing the xenomai user-space tools this would get fixed, but I'm still facing the same issue.

If you have worked with Xenomai or may know the cause of this problem, I will appreciate your help in fixing it.

Thank you.

EDIT

I've found the following error in var/log/messages:

could not find pctldev for node /soc/gpio@7e200000/uart0_pins

It might be that I'm using an outdated version of the Linux kernel. I'll try to update to 4.14.85 which is the last version of the kernel compatible with ipipe.

0

The solution I found to this is to download the 4.14.85 Linux kernel, and use the 4.14.85 ipipe patch.

To get the 4.14.85 kernel I cloned the Raspberry Pi Linux repository with

git clone --depth=1 --branch rpi-4.14.y https://github.com/raspberrypi/linux

and then I applied the kernel incremental patches in reverse, until applying the 85-86 patch.

patch -R -p1 < ../patches-linux/patch-4.14.85-86

Without knowing exactly what caused the problem to begin with, I at least know that running the latest version of Xenomai and ipipe, things like UART and WiFi now work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.