1

I am trying to make a simple robotic car with my raspberry pi. The problem is that when it reaches the white load up screen it immediately reboots itself over and over again.

My raspberry pi is powered through a 9V battery which goes through a voltage regulator (LM350T 5V) and connects to the 5V GPIO pin on the pi. My multimeter shows 4.77V and 1.37A delivered to the raspberry pi. I've read that as long as it's over 4V the pi shouldn't reboot itself so I'm not sure why this is happening. Any advice is much appreciated.

7
  • 2
    Hi @dlam0002 ,Welcome and nice to meet you. Ah, let me see. Your 9V battery is running out. I suggest using 3 rechargeable 16450 batteries in series. 3.7V x 3 = 11.1V should be good. However LM350T is bad, because it is a series regulator which wastes power. Let me see, if Vin = 9V, Vout = 5V, then 9V - 5V = 4V == 4V/9V == 35% energy is WASTED as heat energy. I would suggest to use LM2596 switching regulator which has 90% efficiency: aliexpress.com/i/32895338514.html. Now input can still be 9V or 11.1V, and adjust output voltage to about 5.2V, and your Rpi will be loving it.
    – tlfong01
    Jan 6, 2020 at 12:04
  • Your are welcome. I see that you are making a robot car. Let me give you more links that you might be interested. The first link on "How to build a buggy" is very good for newbies. (1) raspberrypi.stackexchange.com/questions/98513/… (2) raspberrypi.stackexchange.com/questions/99460/… (3) raspberrypi.stackexchange.com/questions/96515/…, There is also a suggestion to DIY a 16450 power bank.
    – tlfong01
    Jan 6, 2020 at 13:28
  • In case you wonder why I use 16450 x 3 = 3.7V x 3 = 11.1V to step down to 5V and not 16450 x 2 = 3.7V x 2 = 7.4V and step down to 5V. The reason is that the switching regulator won't waste that much more energy either from 11.1V to 5V or 7.4V to 5V. If you use 11.1V to start with, you have a bigger margin for the voltage to drop to say 6.5V, you can still go well. On the other hand, 7.4V cannot drop that much percentage and still go well. You may serach for "L298N" in this forum for more suggestions on using power banks for robot cars. Also 11.1V step down to 6V~7.5V is good for toy servos.
    – tlfong01
    Jan 6, 2020 at 13:36
  • And the first of my answers on power bank shows a picture of my 16450 power bank with big by pass capacitors and fuses for using and protecting motors/servos from burning out. (1) raspberrypi.stackexchange.com/questions/98832/… (2) raspberrypi.stackexchange.com/questions/102029/…
    – tlfong01
    Jan 6, 2020 at 13:46
  • And about your comment "I've read that as long as it's over 4V the pi shouldn't reboot itself so I'm not sure why this is happening". I actually did very casual experiment on Rpi stability with an adjustable power supply in the range 3.5V to 5.3V. As you said for my Rpi4B, bleow 4V nothing working. 4V to 5V yellow lightning, still working. Above 5V all goes well, no yellow lighting. But it is only for Rpi4B. I think R2/3 can not work reliably between 4.5 to 5V. But I am not keen to know more about 4V to5V operation. I always work on 5.2V to 5.4V.
    – tlfong01
    Jan 6, 2020 at 14:50

1 Answer 1

2

It reboots because there is not enough power.

Find a better power supply.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.