0

After following some guides, I was able to get a USB SSH connection working from my Windows 10 computer into my Raspberry Pi 4. It won't work on my phone though, even though my phone is capable of tethering. I've tried both the 'IP Neighbors' method and also the static IP address as recommended by the tutorials.

Scratching my head because I originally wanted to do this for my phone to be a direct-connect SSH to RPI4. It just happens to work on the desktop which I don't really care about so much.

The Raspberry Pi 4 USB-C charging cable goes to a power supply on my docking station, which is why the desktop just happens to notice the 10.55.0.1 static IP on the RPI4. When I connect the Android (Samsung Note) from its own USB-C to USB cable into the Raspberry Pi 4 USB port, then I can't connect to it with pinging or with SSH.

Here is what the Android phone says for 'IP Neighbors'

REACHABLE
192.168.42.127 dev rndis0
lladdr 5e:<all that address stuff> DELAY

Here is what's going with usb0:

pi@raspberrypi:~ $ cat /etc/network/interfaces.d/usb0
auto usb0
allow-hotplug usb0
iface usb0 inet static
        address 10.55.0.1
        netmask 255.255.255.248
pi@raspberrypi:~ $ ifconfig usb0
usb0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.55.0.1  netmask 255.255.255.248  broadcast 10.55.0.7
        inet6 <...>  prefixlen 64  scopeid 0x20<link>
        ether <...>  txqueuelen 1000  (Ethernet)
        RX packets 6971  bytes 723210 (706.2 KiB)
        RX errors 0  dropped 5  overruns 0  frame 0
        TX packets 4143  bytes 1380280 (1.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
2

You ignored the note in /etc/network/interfaces:

Please note that this file is written to be used with dhcpcd
For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

Please reset it to its default setting without any stanza:

rpi ~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

and use only /etc/dhcpcd.conf for your configuration if you don't know the impact of using /etc/network/interaces together with dhcpcd. You cannot simply mix it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.