3

First of all, I am sorry about my English.

I used the current last version of NOOBS (1.3.4) to install Raspbian (I guess that it installed the last version of Raspbian, the same as 2014-01-07-wheezy-raspbian.zip).

All seems to work just fine but the wifi connection.

My router uses WPA2 but I tried to use WPA, WEP and even set no security. I also changed channels, SSID, etc... without success.

I also tried several USB chargers (and also plugging the Raspberry PI to an USB computer port) because I thought maybe it was a problem of power supply.

I tried another dongle from another brand and it works fine with wpa_gui. It connects to my wifi and works all perfect.

So the problem seems to be in the dongle itself and not in my router or charger. The wifi dongle I am trying to make it work is an EDUP EP-N8508GS (sold in many online shops specialized in the Raspberry PI). I tried to run wpa_gui as root but it does the same. By the way, I own two EDUP EP-N8508GS and none of them work.

When I open the wpa_gui, it lists the wlan0 and I can scan the access points and I see my SSID listed. Then I chose it and configure it properly, but when I try to connect it just loops all the time, showing the status in "Scanning" and "Associating". The event history (File/Event History in the menu) shows all the time the same (many times the same sentences):

Trying to associate with e0:91:53:5f:18:9c (SSID='WLAN_11' freq=2452 Mhz)

Association request to the driver failed

CTRL-EVENT-DISCONNECTED bssid=e0:91:53:5f.18:9c reason=0

CTRL-EVENT-SCAN-RESULT

WPS-AP-AVAILABLE

It seems that there is a problem with the driver but I can't figure out the solution. I thought the dongle should work out of the box with the new version of Raspbian but it doesn't.

I have tried to install again the whole system several times but I always end with the same issue.

Could anyone help me, please?

Thank you in advance, Joan

  • Did you find a solution? I have exactly the same problem. – Robin Sep 25 '14 at 9:22
  • Diederik de Haas said it nicely. You'll need the driver for the Wi-fi dongle. When you have done that. Try lsusb in the Terminal. The dongle should be listed by then. Raspberry Pi is only supposed to support their own dongles. The rest you'll need to download by yourself. – kuzeyron Jul 31 '17 at 10:03
1

According to WikiDevi you need the rtl8192cu driver, which is now part of the mainline kernel. So just updating your system should fix it.
If not the output of dmesg after you plug in your device will help solve the issue. Also provide the info of uname -a in that case.

  • Also it has to be in the list of lsusb. – kuzeyron Jul 31 '17 at 10:00
0

Try to do it in the terminal:

  • edit your wpa_supplicant.conf file, at the end add line: id_str="edup"
  • check if your proto=WPA

Save and then run these commands:

sudo ifdown wlan0
sudo ifup wlan0

Works like charm for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.