0

When I start the Chromium browser on my RPi it just flashes (no nav bar ever appears).

Here's a gif (video) of what it does: RPi Chromium browser flashes

I'm connecting via VNC.

Details of My Installation

  • Distributor ID: Raspbian
  • Description: Raspbian GNU/Linux 11 (bullseye)
  • Release: 11
  • Codename: bullseye

Things I've Tried

  1. Uninstalling / installing Chromium
  2. Ran Dillo browser - it will run
  3. Updated all software

UPDATED

I just hooked up the RPi to my KVM -- had to pull plugs from my Mac Mini.
I started it up and started Chromium and it loaded up with no problem. Chromium was in an odd state - console window open and no page loaded.

I then went to my Windows 10 laptop (which I've been using all along to VNC to the RPi) and when I connected I set a home page to load automatically just to make sure things would be "normal"

Everything looked fine through VNC while the RPi was connected to KVM and I was seeing everything normal on the connected physical monitor too.

Things Went Bonkers Again

I shutdown the RPi, disconnected the KVM and plugged the RPi in again to allow it to restart.

When it came up I VNC'd to it and started Chromium and it is flashing again.

Guessing - It's Video Driver

So with this, I'm guessing there is something wonky with the video driver or VNC video settings.

Update 2

I started Chromium from the console and I see the following:

console errors from chromium

Then after those lines you just continually see that the browser tries to refresh

browser refresh bogus

Do you know of any way to fix this?

5
  • 1
    Please edit your question and add more details. Does this also happen when you try this locally with connected monitor, keyboard and mouse?
    – Bodo
    Commented Apr 13, 2023 at 14:19
  • 1
    what does the browser window look like after you start it? ... please add a picture ... the video does not stop at the end result
    – jsotola
    Commented Apr 13, 2023 at 17:03
  • @jsotola It never stops. It continues in that loop forever. Seriously. Thanks for asking so I could clarify. 👍🏽
    – raddevus
    Commented Apr 13, 2023 at 17:59
  • @Bodo I connected a KVM and Chromium started up fine. I VNC'd to it while connected to phsyical monitor and Chromium was still fine. After shutting down, removing KVM and then connecting only via VNC I see the Chromium flashing again.
    – raddevus
    Commented Apr 13, 2023 at 18:21
  • 1
    please copy the text and paste it into your question ... do not post a picture of text ... use the {} button to format the text as code
    – jsotola
    Commented Apr 13, 2023 at 20:26

3 Answers 3

1

I solved it by running this command to install Firefox ESR:

sudo apt-get install firefox-esr

And using Firefox instead of Chromium 😀

0

Made two changes to RPi Configuration:

  1. Set video for headless operation
  2. Turned off advanced GL features (set basic feature).

Chromium loads fine and works now from VNC connection.

2
  • I have the same behavior using VNC. Where / how do you make these changes?
    – float
    Commented Jun 10, 2023 at 13:54
  • 1
    @float You'll need to run the rpi configuration tool. Here's the link that will walk you through that: raspberrypi.com/documentation/computers/configuration.html Check out "Interfacing Options"
    – raddevus
    Commented Jun 12, 2023 at 13:20
0

I had exactly this problem. It doesn't happen when an HDMI monitor is connected, so a workaround is to always enable the HDMI output even when nothing is connected by editing the /boot/config.txt file:

sudo nano /boot/config.txt

(Or your favorite text editor instead of nano.) Then un-comment the line 'hdmi_force_hotplug=1' by removing the # at the start.

hdmi_force_hotplug=1

You may also need to set the default HDMI screen resolution, un-comment and update these lines:

  hdmi_group=1
  hdmi_mode=4

HDMI mode 4 is 1280x720, 16 is 1920x1080. You can look up other resolutions. Then save the file & reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.