2

Whenever I login to my Pi via ssh I get this message:

pi@192.168.1.251's password: 
Linux raspberrypi 3.18.11+ #781 PREEMPT Tue Apr 21 18:02:18 BST 2015 armv6l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.

Is there a way how to disable that because it takes up half the screen when I login?

Thanks.

4

As Joan notes, motd is the key. The Debian wiki has good information on how the motd file is generated at boot and how to modify it. Check out the How to keep your /etc/motd from being overwritten section to make permanent motd changes.

If you just want to disable it for your user, create a .hushlogin file in your home directory:

touch ~/.hushlogin

  • removed everything in the motd file and made the hushlogin file and that worked! Thanks. (Also I use vim not pico. :) ) – iProgram May 28 '15 at 16:53
  • I just updated my answer to reflect the fact that debian regenerates the motd file. The wiki shows how to prevent this, but ~/.hushlogin is a lot easier! Oh, and I use vi as well. Just going along with the raspi flow. – bobstro May 28 '15 at 16:56
  • I deleted everything in the motd file and it kepped the changes after reboot. Thanks for editing the answer (only rebooted to check that. :) ) – iProgram May 28 '15 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.