8

I know that there are several threads here that discuss this issue, however none of the solutions have made any difference. Anyway, when I plug in my RPi Camera into my B board, I get this error:

mmal: No data received from sensor. Check all connections, 
including the Sunny one on the camera board

The red light on the camera stays on but will not take a picture. I've updated and upgraded everything. I've also reconnected the ends of the camera ribbon to ensure a proper connection but still nothing has changed. This is the same error I get in my B+ board which I also upgraded and updated.

I've tried disabling and then reenabling the RPi camera in the Raspi-Config, switching the pin used for 1-Wire to pin 18 (as seen here), and a few other methods.

Could it be just the ribbon, or is it the camera board itself? Or maybe there is a software workaround?

Let me know if you need anymore information!

  • Is your power supply good enough? Inadequate power causes all sorts of problems. The B+ has an undervoltage detector, the red power LED blinks off; if it stays on steadily then the power is ok. – tomnexus Jun 26 '15 at 5:50
  • Yeah, I just double checked it on both the B and the B+. Both use a 5.5v power supply from a charger. I still get that same error posted above. – M2com Jun 26 '15 at 23:41
  • Do any messages show up in dmesg after plugging it in? – Wilf Jul 19 '15 at 23:07
  • No, nothing but the message stated above. – M2com Jul 23 '15 at 23:19
  • Have you tried doing a basic electrical test of the ribbon cable? Continuity test each pin at each end to make sure there are no breaks. Many cheap/affordable multimeters include an audible continuity test that can make testing the cable relatively painless. Those cables tend to be pretty sturdy, but it's worth eliminating as a factor. – WineSoaked Aug 10 '15 at 3:15
3

The only fix for me was to purchase a new camera.

  • 2
    I had the same problem, also had to get a new camera. I suspect there is chance of some kind of electrostatic damage to the camera that is possible and the errors you specified are the symptoms. – Piotr Kula Aug 30 '15 at 19:08
2

The "Sunny" connection on the camera board is probably loose. It is the yellow-ish piece of PCB. Try pushing it into the camera board.

  • Unfortunately this didn't fix it. I pressed the Sunny connection in some more but nothing seemed to pop back into place. I still get the same mmal error though. I guess I might just have to bite the bullet and get a new camera. What's odd is that the camera LED is on whenever I submit the command in the terminal. – M2com Aug 25 '15 at 23:15
1

Same story. Try completely disconnecting the sunny one. Then reconnect. it fix for me.

protected by Ghanima Apr 5 '16 at 20:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.