1

My Pi2 is not booting anymore after upgrade to Jessie (using the standard apt-get route).

During boot I get a bunch of messages, the first one is the "A start job is running for dev-mmcpblk01p1.device", which takes about 90 seconds. Then I get messages like

[FAILED] Failed to start Trigger Flushing of Journal to Persistent Storage
[FAILED] Failed to start Update UTMP about System Boot/Shutdown
[DEPEND] Dependency failed for Update UTMP about System Runlevel Change

How can I repair this? I have never worked with systemd before.

  • 1
    Do you have another Linux box? I'd put that SD card in another box and do a file system check if you can. – joan Aug 16 '15 at 12:31
  • I don't think this has anything to do with the filesystem... I think this is more some problem with the new systemd. – Arne Aug 16 '15 at 14:05
  • otherwise this is another possible solution: had the same problem and solved it thanks to your suggestion. it seems there is a problem with the new systemd in jessie and handling raid / tmpfs. cause i wanted to use tmpfs, i switched back to sysvinit like described here: sohcahtoa.org.uk/osd.html - so thats a second way. if sb. finds out what exactly the problem is and how to solve with systemd, i would be great, if you could post it here, – ulph0 Feb 27 '17 at 12:16
2

It seems the problem was caused by me. I was using tmpfs for several directories under /var, to prevend Plex Media Server from spamming my SD-card full of useless logs.

After commenting out the tmpfs sections in my /etc/fstab, everything was fine again.

  • As a note: I still wonder why systemd doesn't play well with tmpfs...? Will have to investigate further. – Arne Aug 16 '15 at 14:14
  • systemd plays okay with my RAM disc. – joan Aug 16 '15 at 17:19
  • Yeah, I have to figure out some other time why this broke everything. Will report back with a solution when I have one. – Arne Aug 16 '15 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.