0

I know that my question may look like trivial, but I spent 2 weeks for it and don't see any solution. I have a Raspberry Pi 2 with EDUP EP-N8508GS wifi dongle and want to setup wifi connection. The dongle was detected by system. I also can find desired hotspot with sudo iwlist wlan0 scan Here is my output of some commands:

pi@raspberrypi:~ $ lsusb 
Bus 001 Device 006: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN Adapter
Bus 001 Device 005: ID 046d:c312 Logitech, Inc. DeLuxe 250 Keyboard
Bus 001 Device 004: ID 046d:c050 Logitech, Inc. RX 250 Optical Mouse
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

pi@raspberrypi:~ $ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
 #   address 192.168.1.100
 #   netmask 255.255.255.0
 #   gateway 192.168.1.1
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

pi@raspberrypi:~ $ sudo cat /etc/wpa_supplicant/wpa_supplicant.conf 
country=GB
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="ASUS"
    psk="MYPASSWORD"
    id_str="edup"
}

pi@raspberrypi:~ $ sudo iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: 00:26:18:C3:BA:22
                    ESSID:"ASUS"
                    Protocol:IEEE 802.11bg
                    Mode:Master
                    Frequency:2.462 GHz (Channel 11)
                    Encryption key:on
                    Bit Rates:54 Mb/s
                    Quality=96/100  Signal level=66/100

pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.4.9-v7+ #884 SMP Fri May 6 17:28:59 BST 2016 armv7l GNU/Linux

pi@raspberrypi:~ $ find /lib/modules | grep 8192cu
/lib/modules/4.4.9-v7+/kernel/drivers/net/wireless/realtek/rtl8192cu
/lib/modules/4.4.9-v7+/kernel/drivers/net/wireless/realtek/rtl8192cu/8192cu.ko
/lib/modules/4.4.9+/kernel/drivers/net/wireless/realtek/rtl8192cu
/lib/modules/4.4.9+/kernel/drivers/net/wireless/realtek/rtl8192cu/8192cu.ko

pi@raspberrypi:~ $ lsmod
Module                  Size  Used by
bnep                   10340  2 
bluetooth             326105  5 bnep
cfg80211              427855  0 
rfkill                 16037  4 cfg80211,bluetooth
8192cu                519156  0 
evdev                  11396  4 
snd_bcm2835            20511  1 
snd_pcm                75698  1 snd_bcm2835
snd_timer              19160  1 snd_pcm
snd                    51844  5 snd_bcm2835,snd_timer,snd_pcm
bcm2835_gpiomem         3040  0 
bcm2835_wdt             3225  0 
uio_pdrv_genirq         3164  0 
uio                     8000  1 uio_pdrv_genirq
i2c_dev                 5859  0 
fuse                   83461  3 
ipv6                  347530  48
8
  • Give this raspberrypi.org/forums/viewtopic.php?f=28&t=69195 a look, first result when I searched: edup ep-n8508gs raspberry pi.
    – Darth Vader
    May 22 '16 at 9:56
  • Thanks for your reply. I've already tried that manual but it gives no result. Raspbian Jessie can recognize my wifi dongle out of box, but I cannot connect to wifi with it.
    – Max L
    May 22 '16 at 10:05
  • Okay, you could have clarified in your question the Pi had detected the dongle. What do you mean by you cannot connect to Wi-Fi with it. I.e what specific bit of the connection process is your problem? If you look in the Wi-Fi manager do you see a list of available networks to connect to?
    – Darth Vader
    May 22 '16 at 10:19
  • Yes, I've included some outputs in pastebin: pastebin.com/09jSACUC
    – Max L
    May 22 '16 at 10:22
  • Everyone else who has asked the same question (there are hundreds) managed to paste config files into their question, which is the normal practice for this site.
    – Milliways
    May 22 '16 at 10:51
1

I've found the solution! The first and main thing to check is WIFI router settings. I had WEP64 encryption selected on router and it was the cause of problem. Just switched to WPA2-personal and everything started to work. Thanks to all who commented above

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.