6

I'm one of the developers on the Motion project.

We are trying to merge the popular motion-mmal fork used by a lot of Raspberry Pi users back into the main project's github repository.

To build with MMAL camera support, the libraspberrypi-dev package is required to be present (and I guess to run, the libraspberrypi0 package needs to be a dependency of the built package too) — so that we can build/run with the MMAL camera interface files.

What is the correct way to achieve this? The libraspberrypi packages aren't present in Debian as a I understand it, so I believe the upstream Debian package can't mention those.

Is the only way to have a completely separate package with a different name that is only available in Raspbian — that seems less than optimal as it means anyone that installs motion will get a version that doesn't support the Raspberry Pi camera, even though the Raspberry Pi support is there in the upstream source code.

I've searched but didn't find much on this subject; https://raspberrypi.stackexchange.com/a/37300/10976 is relevant but I think may be more about the case where the upstream source code doesn't have Raspberry Pi support.

Further confusing me is the fact that raspbian is apparently targeting boards other than raspberry pi, so I don't entirely see how to depend on raspberry pi specific libraries even in raspbian.

migrated from unix.stackexchange.com Sep 1 '16 at 12:39

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems.

  • If you don't get an answer here, you should try a Debian mailing list; I'm not sure what's appropriate for this but worst case is eventually someone will point you in the right direction; under "developers" there's a "mentors" list (presumably, they provide advice...) and also the deity list, where, if they don't tell you to go away because the list is for development of apt not questions about using it, there is sure to be someone who knows the best practice about this. – goldilocks Aug 30 '16 at 13:53
  • Couldn't this be maintained as a separate branch inside the Git repository? – Faheem Mitha Aug 31 '16 at 8:18
  • @FaheemMitha I don't understand how that helps. How do I get the raspbian autobuilders to use that branch? – JosephH Aug 31 '16 at 9:54
  • Hi @JosephH. I can't answer that, because I don't know the Raspian autobuilders work. – Faheem Mitha Aug 31 '16 at 20:13
  • Might be helpful in your future work with rasp building - hackaday.com/2016/09/01/… – slm Sep 2 '16 at 0:47
6

You're correct that you can't add a build-dependency on libraspberrypi-dev to the Debian package, since there is no such package in Debian. You can't even limit the build-dependency to an architecture since both Debian and Raspbian use armhf (albeit with slightly different definitions).

Technically, it should be possible to provide a Raspbian-specific motion package in Raspbian, in the same way that Ubuntu has Ubuntu-specific versions of packages also available in Debian. However, the FAQ states Raspbian attempts to keep the changes minimal so really you should ask Raspbian.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.