1

I have a very hard problem with my raspi. Well, this is the steps I follow:

  • Write a raspbian jessie lite or PiBakery into the SD Card.
  • Boot from the pi, no problem
  • Set internationalization
  • Update, upgrade, rpi-upgrade and install python3.4, dolphin and leafpad
  • Shutdown the raspberry
  • Go to Ubuntu and use dd or clonezilla. Here I start to see errors on the SD, but before I updated the raspbian I have 0 problems.
  • The I inserted the sd again in to the raspi and it won't boot again.

fsck does nothing. I tried with and without it. The SD card is a Samsung SDHC 16 Gb, I saw it in this wiki too http://elinux.org/RPi_SD_cards#Which_SD_card.3F.

Any advice or tip for help?

Update:

It seems to happen after the first boot with a fresh install. The boot partition gets corrupted and if I connect it to another device they didn't read it or say taht is corruped. If I do an fsck or a dd I can't boot again.

  • How are you powering the Pi? How are you shutting down? Have you tried a second card? – Steve Robillard Sep 21 '16 at 20:26
  • Sudo shutdown. Wait a minute after the last led. Remove the power and the card. I use the oficial power supply 2.5A – Oscar Vicente Perez Sep 21 '16 at 20:27
  • O didn't try other sd but this sd only gived problems after updating the raspbian, never before or writing other things. – Oscar Vicente Perez Sep 21 '16 at 20:30
  • If you are consistently "seeing errors" using dd, that is not filesystem corruption, that is a physically damaged/defective/defunct card. – goldilocks Sep 21 '16 at 21:26
  • 2
    You might also want to make explicit exactly what you mean by "seeing errors" using dd. My last comment applies if you are literally getting I/O errors reported while running dd, because the nature of the data involved is completely meaningless to it. You can take a card filled with destroyed data and dd as much of it off as you want, and likewise take random junk and dd it to a card, and there should be no errors reported. If there are, it means somewhere along the line there are hardware problems (or possibly software bugs, but hardware failure is more likely in this case). – goldilocks Sep 21 '16 at 22:03
2

Many SD cards do not work very well with the Raspberry PI. That link you posted is the first place to look at

But even with a well tested SD card, it is very important to poweroff the raspberry PI from the command line sudo halt, then cut power, then extract the SD.

These things are delicate...

  • What is the purpose of posting a link from a question as an answer? Also OP mentions they "shutdown the Raspberry", so it's likely not an unclean shutdown. – techraf Feb 7 '17 at 14:09
  • "Many" may be an exaggeration but there are definitely some cards that do not work with the model A/B. I think this is true to a lesser extent with the microSD based models...in particular some big (64 GB+) cards, but I may be remembering that. – goldilocks Feb 7 '17 at 14:30
0

Your problem is likely rpi-update

"In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". https://www.raspberrypi.org/forums/viewtopic.php?p=916911#p916911

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.