1

Tried using this guide to install NOOBS on a micro SD card. After formatting the card with GParted to fat32 format, I simply unzipped the files from this page (NOOBS_v3_0_0.zip) and dragged all the files to the 16 GB Volume (my SD card).

I then put the SD card in the Pi, plugged in the power cable, and was greeted with the Raspberry Pi logo and an error message reading "Cannot find the drive with NOOBS files".

I tried this whole process three times with no luck. All the guides for installing NOOBS seem to be identical (like this one), so I'm guessing there is some kind of bug.

Update: Looks like this is a known bug.

  • Can you verify what files were extracted and copied to the SD card (perhaps a screenshot/list)? Alternatively check the SHA-256 matches the download page. – trishmapow Dec 14 '18 at 22:37
  • @trishmapow yeah I verified the sha with sha1sum NOOBS_v3_0_0.zip – ChumiestBucket Dec 14 '18 at 22:46
  • What's being discussed in that bug report is the possibility for a user to incorrectly format the card, then proceed without being warned of their mistake. That might be considered a bug (failure to validate user action), but in context this is problematic: There is no point in which to do that if the user is being asked to format a card with a generic tool then copy the contents of a .zip onto it. Neither the formatter nor zip cares what your goal is. – goldilocks Dec 15 '18 at 2:42
2

Follow the OFFICIAL tutorial https://www.raspberrypi.org/downloads/noobs/

Or better still DON'T install NOOBS - install Raspbian instead - preferably using Etcher (most of us don't use NOOBS)

NOOBS claims to be a "simple" installer, but requires formatting the SD Card and a keyboard and screen - but installation requires more steps and is slower than installing Raspbian and wastes SD Card space for the installer.

NOOBS does permit multi-boot, but if you want this I suggest you try PINN (this is an upgraded NOOBS which supports more OS and is a lot more flexible).

SD cards are cheap and 2 small cards are probably cheaper than 1 large card.

  • Not sure how this answers the question - in any case it is a known bug if the card is formatted without MBR as OP has posted. – trishmapow Dec 14 '18 at 22:57
  • 2
    @trishmapow if the OP had followed the instructions the SD Card would be MBR - i.e. this is NOT a bug. But most who try NOOBS once DON'T use it again - this would save some time and angst. – Milliways Dec 14 '18 at 23:01
  • @Milliways it's literally defined as a bug in the NOOBS Git repo as shown in the question. Also the instructions mention nothing of MBR, could you elaborate on how my following the instructions was wrong? Thanks! – ChumiestBucket Dec 14 '18 at 23:19
  • 2
    @star_trac Just because someone files a bug report does not make it a bug. The fact remains if you actually followed any of the tutorials it would work. Your problem was (mis)using GParted. It is impossible to write a program to allow for all the possible mistakes users make. This "bug" is still open 7 months later, and will never be fixed because it is impossible. – Milliways Dec 15 '18 at 1:15
  • 2
    @trishmapow You wrote: "Not sure how this answers the question". But - what is the question? How to find the drive? How to install NOOBS? Is there a bug? What guide to use? – Ingo Dec 15 '18 at 1:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.