14

I've noticed that rebooting my RPi doesn't work. It just halts and doesn't come back up.

To get it back I have to disconnect and reconnect the power.

I'm rebooting using the simple command $ sudo reboot

This can be a problem for two reasons.

  • If you're working entirely over SSH, you have to go to the RPi to get it back on.
  • If you want an always on system (eg webserver or mediacenter) you may want to reboot nightly to keep things running well.

Is this a limitation of the RPi? Can it be worked around?

If it helps, I'm on Debian Wheezy beta.

  • 1
    I don't think I've had problems rebooting with "sudo shutdown -r now". I thought sudo reboot did the same. You will have to reconnect your SSH connections obviously. Also, why would somebody need to reboot a web server daily? There's usually something wrong with your web application if it needs to be rebooted. – Kibbee Jul 5 '12 at 16:14
  • 3
    I am not having this problem, but there seems to be a thread on the Pi forums (raspberrypi.org/phpBB3/viewtopic.php?f=28&t=9079) suggesting it may be a problem with some SD Cards. – Steve Robillard Jul 5 '12 at 16:16
  • @Kibbee According to the man pages reboot invokes shutdown -r when not in runlevel zero or six. – user46 Jul 6 '12 at 15:59
7

My first thought would be this is a firmware issue. Try updating the firmware using Hexxeh's tool, it appears to be the easiest way for Debian users to update (someone please correct me if I'm wrong).

You can download the tool from his GitHub repository here.

Arch Linux users should already have the latest firmware, as it is installed with a standard system update.

  • Spotted a reference to Hexxeh's update on the linked thread above, was going to give it a go. – Jon Egerton Jul 5 '12 at 21:58
  • @JonEgerton: Let us know if that helps. FYI, I had the same problem on my other SD card. Not sure what fixed it. – Jivings Jul 5 '12 at 21:59
  • 3
    OK: My image is Debian Wheezy beta, with full apt-get update/upgrade run. That was about all there was on the image since I decided to start afresh. Installing/running Hexxeh's rpi-update seems to have sorted it. Shutdown doesn't just halt, but the appropriate lights go out etc aswell, and reboot works, with the RPi going down and rebooting afresh. – Jon Egerton Jul 6 '12 at 21:12
  • 2
    Can confirm, from a noob point of view, that using his update is very straight forward. If you're missing dependencies, such as git, it tells you, including how to install what you need. – Jon Egerton Jul 6 '12 at 23:12
1

I'm new to the Raspberry Pi myself, and am not sure if there's something in the hardware that may be quirky, but in my many years of experience with Linux nightly reboots are unnecessary to keep things running well, unlike Windows.

Now, I've had specific programs misbehave and need to be restarted, but usually the only thing that brings Linux down is a catastropic disk failure that you haven't planned for, ill-behaved kernel modules, or physical hardware issues. Of course, I run Debian and not Ubuntu so you may be using newer, slightly buggier software. And of course I don't yet know what specific software is on the Raspberry Pi and may cause issues, etc.

Anyway, to answer your question, you might try kexec - kexec loads a kernel and then runs it. If you load the same kernel you are running, essentially you reboot your system and reinitialize the kernel and all drivers, just as if it were physically rebooted. The kexec package in Debian and Ubuntu hooks into the shutdown process so it can be used to reboot your system instead of the standard method.

  • I'm on Debian, but the wheezy beta (which is apparently better running on RPis) – Jon Egerton Jul 6 '12 at 12:54
0

Have you tried shutdown -n -r now ? This will skip the complete init process and reboots the device. Be sure you have saved your work before trying.

  • See accepted answer - the problem was fixed by a firmware update. Basically the pi wouldn't power off, it just halted. – Jon Egerton Jul 12 '12 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.