I have recently been unable to connect to wifi with my raspberry pi 3 (model B). I have tried a number of solutions to no avail.

The networks button on the upper banner says "connection to dhcpcd lost" or "no wireless interfaces found".

However, when I try iwlist wlan0 scan to search for networks, I can see dozens of wifi networks, including my own. I then go to sudo nano /etc/wpa_supplicant/wpa_supplicant.conf and add my network and password at the bottom of the file. Even following a reboot I have no networks displaying on the upper bar and no wifi connection.

How come in the terminal my raspberry pi recognizes networks, but not in the GUI? How can I resolve this problem to be able to connect?

Any help would be much appreciated.

  • 2
    What Operating System are you running?
    – David
    Commented Mar 24, 2019 at 22:02
  • Are you using an adequate power supply? The first thing to fail if the power supply is weak & weedy is the on-board WiFi. What do you get from iwlist scan can you see your AP's SSID?
    – Dougie
    Commented Apr 4, 2019 at 13:58
  • @Dougie This was my presumption. I can see the SSID. I just ordered an adequate power supply to test that out as well.
    – a.powell
    Commented Apr 4, 2019 at 16:56

3 Answers 3


Instead of editing the wpa_supplicant.conf file, try running raspi-config (or sudo raspi-config) in terminal and choose the option to setup your WiFi connection.

My guess here is that you haven't specified your country yet, which is something you need to add to your wpa_supplicant.conf file. Once you run raspi-config to configure your network connection, if you haven't done it it, you will be prompted to specify your country.

In the end, your wpa_supplicant.conf file should look something like this:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

If the previous doesn't work, then try this

Type ifconfig or ip a to see which network interfaces are enabled. In your case, you're probably looking for wlan0.

You can try to enable all wireless devices by running rfkill unblock all.

Check for any error messages by typing dmesg or look into the /var/log/syslog file.

  • Unfortunately I have attempted this without success. Being in the US I have changed the country code in your code above to US as well as in raspi-config
    – a.powell
    Commented Mar 26, 2019 at 18:07
  • @a.powell, what Operating System are you running?
    – David
    Commented Apr 2, 2019 at 18:45
  • I'm using Raspian (Linux) @David
    – a.powell
    Commented Apr 2, 2019 at 20:25
  • @a.powell, some things you can try (in case you haven't) are typing dmesg in your terminal to see if there are any errors related to your network devices. Similarly, you can use vim or nano to check the /var/log/syslog file and try to find any errors related to configuring your network. I will update my answer to provide more options to diagnose your problem.
    – David
    Commented Apr 2, 2019 at 20:39
  • when I run dmesg there is one line that says: IPv6: ADDRCONF (NETDEV_UP): wlan0: link is not ready. Could this be the source of my problem?
    – a.powell
    Commented Apr 4, 2019 at 1:53

The full answer you can find in this answer .

You can configure your Wi-Fi connection via raspi-config.

Follow next steps:

  1. Go to Raspiconfig, just type in terminal: $ sudo raspi-config

And configuration window will open and looks like the picture below: enter image description here 2. Go to Network Options and choose Wi-Fi.

  1. Fill name and password of the Wi-Fi. SSID - name of your Wi-Fi, Password - password to it.

  2. To be sure, that all configuration work as expected - reboot your Raspberry sudo reboot

  • Thanks for the help. I will re-try this but have done so multiple times including the reboot with no success
    – a.powell
    Commented Mar 28, 2019 at 20:56
  • The last chance is to save important data and flash the new OS on microSD.
    – romankh3
    Commented Mar 29, 2019 at 8:48

I think that the correct answer has already been given, but it may be that there's something else going on. Have you looked into the system log to see if there's any useful information there? run journalctl and then scroll through looking for dhcpcd and wpa_supplicant log entries.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.