Whenever I try to upgrade on raspbian it says, "E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Nothing I have tried yet works. It also was like this when I used Ubuntu and Manjaro.

Thanks in advance for any solutions

  • Hello and welcome -- Add what exactly you have tried to solve the problem.
    – M. Rostami
    Feb 22, 2020 at 18:18
  • Try running sudo apt update (the more modern command than sudo apt-get update). Then runsudo apt dist-upgrade -y to try again.
    – Dougie
    Feb 22, 2020 at 21:00
  • I am not sure if you are asking a question like this "Should I upgrade if I found anything interesting?" or this "Should I be the first user?" My answer is yes, and no, it all depends how are your engineering trade off or business cost benefit analysis. I am a die hard Winows guy, and I have only used serious Raspbian for about 5 hobbyist years. I think I have spent perhaps 100+ hours in end-up-failure upgrades, each "wasting" 3+ hours. Yes, they all ended up failures, but then I learnt many linux tricks that I-didn't-know-that-I-didn't-know. So I see all of them good learning experiences.
    – tlfong01
    Feb 23, 2020 at 2:10

2 Answers 2


It's a common problem with Linux users.

Remove content of /var/lib/apt/lists directory by:

sudo rm -rf /var/lib/apt/lists/*

then run it:

sudo apt-get clean
sudo apt-get update


sudo apt-get upgrade --fix-missing
  • 1
    thanks, it worked for that. Although after I downloaded chrome 64 bit for deb, I tried to install it using terminal, it came up with this error, if you have any solutions to that too it would be extremely helpful. pi@raspberrypi:~ $ sudo dpkg -i google-chrome*.deb dpkg: error processing archive google-chrome-stable_current_amd64.deb (--install): package architecture (amd64) does not match system (armhf) Errors were encountered while processing: google-chrome-stable_current_amd64.deb Feb 22, 2020 at 18:41
  • 1
    @BalboBiggans That should be asked as a separate question, thanks: raspberrypi.stackexchange.com/q/108646/5538
    – goldilocks
    Feb 22, 2020 at 19:51

I have this problem when upgrading

You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: libgeotiff2 : Depends: libproj13 (>= 4.8.0) but it is not installed libogdi3.2 : Depends: libproj13 (>= 4.8.0) but it is not installed libspatialite7 : Depends: libproj13 (>= 4.8.0) but it is not installed proj-bin : Depends: libproj13 (>= 5.0.0) but it is not installed python-gdal : Depends: gdal-abi-2-4-0 Depends: libgdal20 (>= 2.4.0) but it is not installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Dec 28, 2021 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.