2

I got my first 2 pies yesterday, and they are indeed funny to play with.

But I have a problem, when I try to mount my NAS server to pi1, nothing happens. - Funny is that I do the same thing on pi2, which works just fine.

Totally same cmd I trow at them.

I use this in fstab to mount the drive: //NAS-IP/Save/pi /home/pi/NAS/data cifs username=USERNAME,password=PASSWORD 0 0

I formatted the one it worked one, I'm going to try again on that one soon.

But, I do not understand it work on 1, but not another?

thanks guys

  • It indeed seem strange. I would try mounting manually - that is with the full mount command. Maybe you even want to remove the fstab entry, or mount it to another path, and see if you get some kind of error message. Also, it might be worth checking if your NAS has some limitations on how many clients can mount at the same time. – Bex Apr 20 '14 at 11:42
  • I've never needed to mount before, so could you point to the right direction with a full/manual mount? they connects thru different NAS users, so shouldn't be a problem? – Convertor Apr 20 '14 at 11:44
  • The manual command is sudo mount -t cifs -o username=USERNAME,password=PASSWD //NAS-IP/Save/pi /home/pi/testmount Try that and see if you get an error message back. You want to create the directory testmount first. – Bex Apr 20 '14 at 11:51
  • hmm, it might be my password it can't read, I've got this when tried -bash: <My Password>: event not found, my password does contain special symbols, but again it worked on the other pi.. the other one is almost done compiling, I'll try one that one again also. – Convertor Apr 20 '14 at 11:54
  • Your password doesn't happen to contain an exclamation mark, does it? While special characters in the password are generally a Good Idea, you might want to try a simpler one, one without characters that has a Very Special Meaning to shells, just to check if it works. – Bex Apr 20 '14 at 11:57
1

This turns out to having to do with the password for one of the NAS users contained an exclamation mark !.

When trying to mount manually, this will be interpreted as a reference to execute the last command beginning with the rest of the password - when no such command is found, the shell will say event not found - read bash man page for reference.

Using ! to prefix a password is also a common way to disable a user account in various configuration files in unix.

I'm not entirely sure what is at play when using ! in a password in fstab - but it seems it doesn't work.

  • Just an comment, the exclamation was not in the beginning, was in the middle, but the bash error returned from where the exclamation begins, so no exclamation in the password at all – Convertor Apr 20 '14 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.