4

After updating from raspbian wheezy to raspbian jessie networking isn't working properly anymore.

Folllowing lines seem to describe the error:

ifplugd(eth0)[184]: Using interface eth0/B8:27:EB:0E:CD:AA with driver <smsc95xx> (version: 22-Aug-2005)
ifplugd(eth0)[184]: Using detection mode: SIOCETHTOOL
ifplugd(eth0)[184]: Initialization complete, link beat not detected.
ifplugd(lo)[203]: ifplugd 0.28 initializing.
ifplugd(lo)[203]: Using interface lo/00:00:00:00:00:00
ifplugd(lo)[203]: Using detection mode: SIOCETHTOOL
ifplugd(lo)[203]: Initialization complete, link beat detected.
ifplugd(lo)[203]: Executing '/etc/ifplugd/ifplugd.action lo up'.
ifplugd(lo)[203]: client: /sbin/ifup: failed to open lockfile /run/network/.ifstate.lock: No such file or directory
ifplugd(lo)[203]: client: run-parts: /etc/ifplugd/action.d//ifupdown exited with return code 1

But whats wrong, or what's the solution?

Note

This does not happen every time.

Could it be that sometimes our beloved systemd gets wrong its execution order? ...and then tries to start networking before /run/network/ is fully mounted or such a thing?!

8
  • 1
    I also had some problems with jessie, when I tried to connec to a DSL via NetworkManager. It seemed that it didn't work and because I didn't have time to search for a solution, I reinstalled wheezy. What can I say is that I think the problem is not just in the distribution for arm architecture. I had the problem on an i386...
    – 23ars
    May 10 '15 at 20:41
  • So it would nice to hear from somebdy experienced with systemd...
    – Matthias
    May 11 '15 at 11:43
  • 2
    "Could it be that sometimes our beloved systemd gets wrong its execution order?" -> More likely whoever configured the ifplugd service for Raspbian systemd screwed it up (ifplugd is not used by default on Debian or other regular distros). If you don't want to bother investigating that, you could just uninstall ifplugd; its only purpose is to autoconfigure ethernet when you plug a cable into a headless system, and I suspect it is more a cause of grief than anything else (you don't need it to if you are booting a headless system with the cable already in).
    – goldilocks
    May 11 '15 at 11:51
  • 3
    You should probably also report this as a bug: raspbian.org/RaspbianBugs
    – goldilocks
    May 11 '15 at 11:53
  • Do you have any ifup rules? i.e. /etc/udev/rules.d/85-ifupdown.rules
    – Doug Edey
    May 11 '15 at 13:04
1

I faced the same problem and could solve it by upgrading to NetworkManager:

sudo apt-get install network-manager

Then, disable all entries in /etc/network/interfaces since this gets replaced by NetworkManager.

In my case I did not even need to configure the NetworkManager by nmcli because my LAN connection was automatically detected and configured after reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.