0

When I run lsusb (on a separate keyboard) the keyboard that I have to use shows up but when I press any of the keys it doesn't input. The keyboard used to work on the RasPi and still works on a Windows computer, but just not not the Pi. Another interesting thing is that when I push the Num Lock button on the working keyboard, it lights up on the not working one.

I have tried all combinations I can think of of plugging in the working and not keyboard with the power on and off. Also I like to avoid using a different keyboard because the form of the not working keyboard has been altered to fit in the setup I need.

Also, the OS is Jessie Lite if that matters.

Edit: I tried two different powered usb hubs and it did not fix the problem

1

Seems like power issue are you powering the pi from USB? If so power it directly. If it is possible, get another keyboard and check if it is working. If the other keyboard works then it is a power issue with your current keyboard. If it is a power issue then you can try connecting your keyboard via an external powered usb port. If you have ethernet cord or wifi usb connected to your pi remove them and test if your keyboard is working.

  • I used the powered hub this morning and no dice. – EyesForDays Mar 30 '16 at 15:24
0

I took the drastic route and it worked. I re-imaged the SD card and the keyboard works just fine now

-2

I had the same problem (numPad worked, numbers worked, sometimes enter worked but nothing else). I don't know the solution for you but here is what I did for the other people:

The keyboard is 50 mA HP keyboard and I have a 1500mA power source so I doubt it is a power issue. Tried to unplug other devices. Did not work. I changed it for another keyboard (100 mA generic brand) and everything works now (so no power issue).

I looked around and the cause might be a crystal failure so I tried the Ethernet (it would not work if this was the issue) and it worked. So no crystal issue.

I tried to reinstall the system like you. Tried jessee, jessee-lite and ubuntu. The problem was the same on all three. Tried to go into keyboard configuration and change the layout. Didn't work. Also tried to change the model of the keyboard (can't recall how I did that, will add commmand later, maybe rasp-config) and didn't work.

It is probably a hardware compatibility issue with me. Keyboard works on a normal PC. Just not the raspberry PI. Solved by switching to another keyboard.

  • Telling someone to buy new hardware is not an answer, secondly your answer is not clear. (Review your last sentence). Finally you have not given an explanation as to how the question asker could proceed with diagnosing the problem. Or have included a link which might solve their problem. – Darth Vader Apr 2 '16 at 11:35
  • Well I had my keyboard lying around. I had the same problem and stated my solution without making wild claims about the source of the problem like some. I ruled out the power issue and the crystal misconfiguration since ethernet worked fine as well as other devices, which required more power. Also ruled out software or OS issue by trying out three versions of OSes. What more do you want me to do? Sit around and complain about others actually trying to help? – furcino Apr 8 '16 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.