1

My wifi dongle is seen by my Pi and has its own IP address.

Issue is when I unplugged my RJ45 cable from the PI, the wifi dongle is not transmitting signal (or is it) and I can't connect to the PI.

When doing an arp -a without the rj45 cable plugged , this is what I have

? (192.168.1.16) at (incomplete) on en0 ifscope [ethernet]

Although it is implicit, I'm mentionning it again: I can't connect with ssh when the cable is unplugged.

After replugging the RJ45 cable and doing again arp -a, this is what I have

raspberrypi.home (192.168.1.16) at f4:f2:6d:1d:55:5e on en0 ifscope [ethernet]
raspberrypi.home (192.168.1.18) at b8:27:eb:9c:12:d9 on en0 ifscope [ethernet]

The IP 192.168.1.16 is the one used by the wifi dongle (the command used to figure that out is ip addr)

This is my wpa_supplicant.conf content update: I've changed the initial content of the file. The content below is what I have changed

#country=GB
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="Livebox-Fxxx"
    psk="Password"
}

This is the content of my /etc/network/interfaces update I've tweaked the file to have this. I did not keep the initial one (stupid me!)

# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

# manual originally

#iface eth0 inet dhcp

auto eth0
allow-hotplug eth0
iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

I tried to do a ifdown wlan0 and then restart the service with a ifup wlan0 and each time I have the following error

ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument

Update: I've unplugged the RJ45 and this what I have after doing an arp -a

raspberrypi-1.home (192.168.1.16) at (incomplete)

What means the (incomplete) thing?

  • 1
    Frankly I don't actually know what you are asking. You haven't described your network configuration or what you have actually tried or even WHAT doesn't work. You have obviously changed some of the default configuration files (WHY?) which should work out of the box. There are literally hundreds of similar questions on this site, have you tried these? – Milliways Sep 12 '16 at 3:33
  • Hi @Milliways please see my updates above. I amended the wpa_supplicant.conf and also the network interfaces but to no avail. I don't know what's wrong. I don't have any understanding of what I can change. Yes, I've checked the many posts on the forum but it did not help – Andy K Sep 12 '16 at 17:00
  • A few things you could try: 1) Use a more reliable power supply with a higher amperage rating. Typically wifi dongles require quite a bit of power when transmitting but might appear to be detected / working when Idle. 2) Tell us what wifi model you are using. I've had hard times in the past getting RTL8188eu based dongles working with raspbian/wheezy because of driver / custom hostapd requirements. – Shreyas Murali Sep 14 '16 at 17:57
  • It's a bit odd here that your configuration refers to eth0 but the arp output refers to en0. You haven't upgraded to stretch/testing, have you? – goldilocks Sep 14 '16 at 18:31
  • hi @goldilocks what do you mean by stretch/testing? – Andy K Sep 14 '16 at 18:46
2
+25

I still dont have enough rep points for a comment, so here's one more answer. Please feel free to change it to a comment.

I searched around for the error messages and came across strangely familiar posts I must have seen during my prior experiences with realtek chipset based wifi dongles.

https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=104856 https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=104974

According to the last entry in first link someone had success by calling wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant/example.conf -D wext

Second post seemed to point to a version incompatibility of the wpa_supplicant and the kernel driver.

I'd suggest trying

  • share the details of the chip set using the output of lsusb
  • check if the dongle is working by connecting it to a laptop or desktop
  • updating the realtek firmware using sudo apt-get install firmware- realtek
  • as a worst case measure, try a fresh start if you have a spare card lying around, write the latest raspbian or NOOBs image and try to see if the problem persists. Ideally it would be nice to find the problem rather than redo from start, but in this case a fresh start might reveal if the problem occurs out of the box or is probably because of the customizations.
  • hi @shreyas-murali , please leave it as an answer. Thanks for your help – Andy K Sep 15 '16 at 5:38
  • Hi @shreyas-murali, thanks. I've reinstalled everything , went through the graphical interface and now it is all setup. Starting the real work now. Thanks – Andy K Oct 2 '16 at 16:47
0

When you disconnect the Ethernet cable, you still have entries in kernel routing tables going through eth0. Those entries usually have higher priority than wlan0 ones, which is the setting most people want.

In that case disabling the interface with ip link set dev eth0 down should update the routing table and solve the problem. Use ip route list to diagnose.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.