2

I've booted up my RaspberryPi with the Belkin N300 Wireless Adapter, which has worked great for most of my other debian systems. The dongle is recognized by raspbian, both by lsmod and lsusb.

$ lsmod
Module  Size    Used by
.....   .....   .....
8192cu  490353  0

$ lsusb
.....
Bus 001 Device 004: ID 050d:2103 Belkin Components F7D2102 802.11n N300 Micro Wireless Adapter v3000 [Realtek RTL8192CU]

The dongle can be utilized to scan for a wireless network.

$ iwlist wlan0 scan
wlan0   Scan completed :
    Cell 01 - Address: 00:14:D1:3D:9E:01
              ESSID:"TRENDnet"
              Protocol:IEEE 802.11bg
              Mode:Master
              Frequency:2.437 GHz (Channel 6)
              Encryption key::on
              Bit Rates:54 mb/s
              Extra:wpa_ie=dd160050f20101000050f20201000050f2020100050f202
              IE: WPA Version 1
                  Group Cipher : TKIP
                  Pairwise Ciphers (1) : TKIP
                  Authentication Suites (1) : PSK
               Quality=100/100 Signal level=86/100

But for some reason, the dongle won't connect to a wireless network.

$ sudo ifconfig wlan0 up
$ sudo iwconfig wlan0 essid "TRENDnet" key s:"spiffy333"

$ sudo dhclient wlan0
RTNETLINK answers: File exists

After researching the issue for a while, one source instructed me to try configuring it while booting.

$sudo nano /etc/network/interfaces
auto lo

ifaceo lo inet loopback
iface etho0 inet dhcp

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
    wpa-ssid "TRENDnet"
    wpa-psk "spiffy333"

But this is all it prints out during boot!

Listening on LPF/wlan0/08:86:3b:34:26:29
Sending on LPF/wlan0/08:86:3b:34:26:29
Sending on Socket/fallback
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
DHCPOFFER from 192.168.1.1
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.101 -- renewal in 262895 seconds.
ifup: interface wlan0 already configured.

I'm really quite confused; is the dongle somehow partially incompatible with the RaspberryPi, in that it can scan but won't connect? Or am I trying to connect to the wireless network incorrectly?

  • I have a TP-Link dongle which works fine on an x86-64 based linux system, but has some (minor) issues on the pi. I don't know if the glitches are because the dongle is underpowered there, or because the ARM6l version of the kernel is imperfect (there are no errors reported, but, e.g., the led on the dongle always blinks with the pi, whereas elsewhere it just stays on while connected). – goldilocks Sep 2 '13 at 16:52
2

DHCPACK from 192.168.1.1
bound to 192.168.1.101 -- renewal in 262895 seconds.

That means you're connected, and you have an IP Address of 192.168.1.101

If you run iwconfig, you should see something like -
wlan0 IEEE 802.11bgn ESSID:"TRENDnet"
       Mode:Managed<snip>

The Mode:Managed means it's connected.
Are you having other issues ?

0

I set up my /etc/network.config file like this and it worked for static IP

auto lo
iface lo inet loopback
iface eth0 inet dhcp
allow-hotplug wlan0
auto wlan0
iface wlan0 inet static
address 192.168.0.6
netmask 255.255.255.0
gateway 192.168.0.1
wpa-ssid "YOUR_SSID"
wpa-psk "YOUR_PASSPHRASE"

For DHCP it was very similar

auto lo
iface lo inet loopback
iface eth0 inet dhcp
allow-hotplug wlan0
auto wlan0
iface wlan0 inet DHCP
wpa-ssid "YOUR_SSID"
wpa-psk "YOUR_PASSPHRASE"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.