3

I currently have a Rasberry Pi B, one of the very early ones, I installed a fresh version of Raspbian today and everything was fine. I let the system update after the first boot and let it restart. Everything was normal. I then added Grafana, speedtest.net, and InfluxDB. I then created some python files, tried to open Chromium but it wouldn't open.

I then tried to restart the system and it has never booted to the desktop since. It gets through the initial boot from what I can tell, it shows me the logo and all the programs its loading. Then it just sits at a black screen with a blinking cursor. I can press ctrl+alt+f1 and I can see a command line appear but then it's removed a second later.

Any ideas about what has gone wrong with it? Is it because I'm trying to use and old Pi with new software?

I'm really new to linux so feel free to explain lots to me :) Any help would be appreciated Cameron

  • What does it mean: "I can see a command line appear but then it's removed a second later". You should get a login prompt where you are able to enter user pi and its password to get a shell prompt with a commandline. Is this possible? Just type Enter first. – Ingo May 21 at 19:32
  • 1
    Please install again and let us know the result. – Sohan Arafat May 31 at 20:19
  • @SohanArafat It works, please see answer marked as the solution below – Cameron Ward Jun 1 at 16:16
2

From what I see, it is possible that you installed too much for what the computer can handle. You either may want to reset the Pi or buy a newer one with 4 GB of Ram with a 64 GB SD card. If you do decide to reset, boot into recovery mode by holding shift on a connected keyboard until it appears.

In general, the Raspberry Pi computers can't handle too many installations at once, compared to a Windows PC or a Mac.

| improve this answer | |
  • I was thinking of buying a new pi. When you say too many installations, do you mean all at once without rebooting in between or do you mean in total? – Cameron Ward May 21 at 9:02
  • More likely installing too much at once. But maybe too much to load for the older Pi to run. – Macintosh Fan May 21 at 17:54
2

So I gave up and decided to reinstall the OS onto the SD card using the Raspberry Pi disk imager. I then went and installed all the programs as mentioned previously but this time I didn't enable the programs on startup. This seems to have fixed it and it's running perfectly now. :)

| improve this answer | |
  • Cool. Something I learned :) – Macintosh Fan May 23 at 22:46
1

I don't know anything about grafana, but if you have a brick, one option is to take the sdcard out and mount it on another system and try to isolate things by disabling one thing at a time via init files, then put the sdcard back into the pi and try. Another thing, although you didn't mention you made any network changes, there was a time a particular image I had would hang if it didn't have networking up, it was a broken image but something to check anyway.

Sorry I can't think of anything else right now.

| improve this answer | |
  • Thanks for the answer! What would be the best way to go about mounting it to another system? I have a Windows machine, would there be a way of loading the contents of the SD card onto a Raspbian OS on there? – Cameron Ward May 21 at 9:00
  • Take the sd card out of the pi, you'll likely need a cradle to hold the sd card unless your PC has direct slot to accept an SD card. Once you put the sd card into the cradle (btw the cradle is just an adapter to hold the sd card), it will probably auto-mount on your PC. I'm sorry I don't have access to a windows PC at the moment but try it. If your PC is linux, it will automount the sd card automatically. If it doesn't, look in /var/log/messages after you insert the sdcard, you should see something like mmcblk0 mmc0:0002 SD 14.9 GiB, your device might be different. – myT250 May 21 at 22:53
  • CONT... in this example, mmcblk0 is the whole sd card, you'll have to mount the partition, you can use fdisk or something else to find what partitions, then mount it like this.... mount /dev/mmcblk0p1 /home/mydir/mountpoint – myT250 May 21 at 22:58
  • Thanks, I did mount it to my windows machine but changing the init file to enter safe mode but even that didn't work. I had to reinstall the OS and start again. – Cameron Ward May 22 at 10:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.