4

Ok I am giving a shot at this, try following the mentioned steps (type in your Terminal): create a folder called 'lxsession' in your hidden folder called .config: $ mkdir /home/pi/.config/lxsession Depending on your Raspberry Pi Version you can try : $ mkdir /home/pi/.config/lxsession/LXDE-pi/ OR $ mkdir /home/pi/.config/lxsession/LXDE/ now create a ...


2

You should edit ~/.config/lxsession/<profile>/autostart if you have it, or make sure it is removed if you need a global LXSession configuration for all users. If you happen to have both files, the global configuration will be ignored: Commands globally executed are stored in the /etc/xdg/lxsession//autostart file, and in addition, other commands can ...


2

It worked, thanks to all who had input (eps Shan-Desai) Okay what I did: 1) Fresh install of Noobs (Raspbian Jessie) 2) sudo apt-get update. 3) sudo apt-get upgrade. 4) sudo apt-get install firefox-esr 5) Then I tried to follow Shan-Desai's advice above with: create a folder called 'lxsession' in your hidden folder called .config: $ mkdir /home/pi/....


2

If you had SSH, you could go back and rewrite it back to the original. If you can access your files, back them up on a USB, and reinstall your version of Raspbian. I would like it for you to provide picture so I can give more to this answer.


1

It's unclear why you're just now looking for a solution, given the importance you attach to your files, and the impact of a loss. But I'll leave that for you to ponder. In the meantime, I would guess that each time you use the SD card to boot and run, your prospects of permanent loss increase. I'd stop that right away, and get on with the backup process. ...


1

To open two chromium windows (and not have them "stick together" as 2 tabs in 1 window), simply add this to both commands in your lxsession autostart: --new-window I found that command line flag by typing this: chromium-browser --help


1

After two days, and a lot of work troubleshooting, I've fixed the problem by: a) Inserting my problematic disk into another computer b) Unmounting the directory (it was automatically mounted) by umount /dev/sda1 c) Running sudo fsck /dev/sda1 It turned out to be a bad bit, and now the problem is all fixed. For future reference, the problem wasn't LXDE, ...


1

If you just want to prevent your Pi from going into sleep mode you could just change lightdm which manages sleep mode. Go into the config file: sudo nano /etc/lightdm/lightdm.conf and add the following line: xserver-command=X -s 0 dpms Edit: I just noticed you're probably following a guide for the Raspberry Pi 4 where indeed that directory and file ...


1

I haven't used LXDE so far but from a graphical user interface usually you can get to a text console by pressing {ctrl}{alt}F1 (..F2-F6). When you can switch to it then login and repair the settings. You can go back to the GUI with {alt}F7 but in your case there is only a black screen with blinking cursor so you should reboot.


1

There are various ways of running a command at startup, but you do need to make sure of certain things first: Check the permissions of your file, if you think they are correct, temporarily change them to 777 (chmod 777 /path/to/script) and try that Make sure the command/script works manually, which you have done Make sure that the command/script either runs ...


1

In the /etc/xdg/lxsession/LXDE-pi/autostart file, ${HOME} and ~/ don't seem to work. Instead, as a work around, put in an absolute path. The line should therefore look like: @/home/<you>/.config/lxsession/LXDE-pi/autokey.sh


1

I use crontab because it is simple and equally useful for running all kinds of automated scripts regardless of the Linux/Unix system you happen to be using. This is also answered on this question. Below, my own code: Open crontab: sudo crontab -e Instead of the usual crontab format for date (eg. */5 * * * * script_name) use @reboot: @reboot sudo python /...


1

The only solution I'm aware of that lets you connect to the same session that is on a local screen is X11VNC, "a VNC server for real X displays". What you'll need is X11VNC on the Pi and some form of VNC client on your remote device. Install X11VNC sudo apt-get update sudo apt-get install x11vnc Set a password (you can skip it but probably don't ...


Only top voted, non community-wiki answers of a minimum length are eligible