Hot answers tagged

16

Jessie Lite does not contain the GUI packages just the command line. If you want a GUI you will need to install the packages to your existing SD card or reflash the card with the full Raspbian Jessie. The latter is probably the better approach. Note though that this may require a bigger SD card than you are currently using.


9

If you enter sudo raspi-config there will be an option to boot directly into the gui at boot time, enable it, reboot and you'll probably be fine. In this picture the third option will fix your issue. . Kind regard Michielvk


9

This is what I did for a basic "no DE (desktop environment)" setup. There are probably better posts out there for specfic DEs. But this post seems to be about simple Xorg setup and being able to run it on the command-line using startx. For my tests, I used a fresh "Raspbian Jessie lite". The packages I installed: sudo apt-get --no-install-recommends install ...


5

The steps below install PIXEL, the official Raspbian desktop environment included with the full version of Raspbian. After installing Raspbian Lite, setup your password, enable ssh, configure Locale and network etc. Ensure Raspbian is updated to the latest software. The essential step is to install the Xorg Display Server sudo apt-get install --no-install-...


4

The fact that dpkg -l | grep raspberrypi-ui-mods doesn't output anything indicates that you probably do not have the desktop version installed. You certainly don't have the default Raspbian PIXEL packages on your system. Since you have no GUI, you don't have startx either. The GUI starts automatically on the full version of Stretch with Desktop, so it is ...


3

Are there any way to make X server to load/show its root window already with an image in it? Probably not completely, but keep reading. Although the 3 is the fastest pi, it is still not something that is on a par with, e.g., current x86-64 processors. You could compare this to your smartphone. I have a fairly new, fairly fast, Snapdragon "octocore" (8 ...


3

RPi Jessie not working ? I think you want to use the autostart here: /etc/xdg/lxsession/LXDE-pi/autostart or: ~/.config/lxsession/LXDE-pi/autostart not here: /etc/xdg/lxsession/LXDE/autostart ...at least with the default Raspbian setup of LXDE.


3

Yes it is possible. I took a look at the link that is provided and that make me on track, for my concern and now i can give a little back. First: I have createt a 99-fbturbo.conf in /etc/X11/xorg.conf.d/ And also ensured that there is not another .conf, that will interfere with / change /dev/fb0 in: /usr/share/X11/xorg.conf.d/ My /etc/X11/xorg.conf.d/99-...


2

When I set it up, turn it on, and get to the part where I need to type in the "startx" command and press enter it does not work. That is not entirely true! It does start the X server - which fires up and then dies as it is reporting that it terminates successfully according to (the middle part of) that last line: waiting for X server to shut down (EE) ...


2

Download the latest Raspbian Stretch with Desktop (currently 2017-09-07) : https://www.raspberrypi.org/downloads/raspbian/ Flash to sd card using Etcher (on Mac,PC,Linux) : https://etcher.io Note : sd card does not need formatting, nor the image file unzipping with this process Place sd card into Pi and boot


2

/etc/profile is the system-wide .profile file for the Bourne shell It will run EVERY time you start a shell - it DEFINITELY is NOT intended to run programs on login, but to configure the shell.


2

Here's what worked for me: rm -r /home/pi/.config/libfm rm -r /home/pi/.config/pcmanfm sudo reboot And then the third one reboots your Pi (necessary) Those first two rm commands remove the file manager's configuration. See more at my thread question.


1

If you happen to use LightDM, the correct file to start your GUI apps before the desktop environment starts is /etc/lightdm/Xsession. If you want to configure startup differently for each user, you typically put there a line [ -f ~/.xprofile ] && . ~/.xprofile and then configure the startup for a given user by editing their ~/.xprofile.


1

If you want to skip loading the desktop, I would suggest not using the .xinitrc route, but replace loading the session with your own program. Create ~/.xsessionrc with one line STARTUP= Create ~/.Xsession with whatever you want to start. You might want to throw in a few lines to avoid screen blanking and screen savers: #!/bin/sh xset s off ...


1

Adding Answer due to lack of ability to add comment to @CoderMike's answer It is important to note whether you have RASPBIAN STRETCH WITH DESKTOP installed or RASPBIAN STRETCH LITE. Stretch LITE doesn't have a GUI installed, hence the LITE. If this is the environment you are booting into this could be the issue. The GUI doesn't exist. Note: I installed ...


1

Raspbian Stretch with Desktop requires an sd card with a minimum size of 8GB. I tend to use 16GB sd cards. https://www.raspberrypi.org/downloads/raspbian/ The Raspbian with Desktop image contained in the ZIP archive is over 4GB in size, which means that these archives use features which are not supported by older unzip tools on some platforms.


1

In my case, the following command worked to launch X: sudo mount -o remount, rw / If I understand correctly, this gave X access to the /tmp directory that it wanted. Before the filesystem was read-only. Now tty7 is running the desktop properly.


1

It looks like there was a problem with tightVNC after removing it now the desktop starts properly Edit: after few days I got the problem back.


1

Yes, all this is possible but the fact that the script may include a (graphical?) user interface makes it a complicated task. I'd advise you break it down and tackle, in order: Getting the logging script to run on boot without any potential foreground UI. Get the same (background) script to respond to commands -- this means a client/server architecture, ...


1

it takes me to LXDE login screen Technically that's the lightdm login screen, LDM, where "DM" is short for display manager. You are not wrong in the sense that it is sort of in use by LXDE and I think maintained by the same people as part of there project, but wrong in the sense that it does not by necessity log you into LXDE. That depends on how it is ...


1

This is usually caused by a stale lock file from a crashed previous session. As root, look for an existing /tmp/xtX0-lock and delete it, then try starting X again. Being out of drive space will also do it. Try deleting everything under /var/log, then use sudo apt-get erase <packages...> to perhaps remove some packages you don't actually need. NOTE: ...


1

I had the same problem after I messed up my .xsession-script. Rebooting wouldn't help and username as well as password were correct. However, you can still access your Pi using SSH (e.g. using Putty on a Windows machine or ssh pi@<yourIPaddress> on Linux/Mac OS X) and then retrace the steps that created that mess in the first place (most likely ...


1

The vt used can be specified as an argument/option when starting the Xserver - it is vt# where # is a number greater than zero and will (must?) be after the display(.screen) number, typically :0 - note that a leading - is NOT used for this option. Depending on the display manager this may be influenced by settings in the configuration for that. For example,...


1

Try something as minimal as possible. First: sudo apt-get install xterm Now create an xinitrc file for your current user: echo '#!/bin/sh' > ~/.xinitrc echo xterm >> ~/.xinitrc chmod 755 ~/.xinitrc Check that it looks like the below w/ cat ~/.xinitrc: #!/bin/sh xterm Now, as the same user, try startx. You should end up with a plain black ...


Only top voted, non community-wiki answers of a minimum length are eligible