Hot answers tagged

6

While I don't have Arch Linux to check if this, it's probably mounted by kernel itself and never remounted. You can check your /proc/cmdline and you should see something like root=/dev/mmcblk0p2 and rootfstype=ext4 options. You can set them in /boot/cmdline.txt file. First one specifies which device (partition) should be mounted as root device, second one ...


5

Since I found the solution myself, I am posting it here, very grateful to every author of the raspberry pi forum posts. 1. Part 1 - getting command line in the boot Error Got "Cannot open access to console, the root account is locked." error. Solution Mount the SDCard on another computer (any type). Tip: if you don't have a SDCard reader on your ...


4

I'm assuming you have full-size personal computer to work on, otherwise where would your share be connected to! So..., can you mount and read the SDHC card from the Pi on that PC? If you think you might be able to, the read on: My Debian Linux machine automatically mounts and attaches all the partitions it can find on the card from my Pi if I insert it ...


3

I used raspbian lite, and sshfsisn't installed by default. So I installed it with sudo apt-get install sshfs Then I added it to the /etc/fstab pi@192.168.2.95:/mnt/4TB/ /mnt/files fuse.sshfs identityfile=/home/pi/.ssh/id_rsa,allow_other,defaults,default_permissions,uid=1000,gid=1000 0 0 So now the files are available on the remote Raspberry Pi via ...


3

I did it with these instructions and it worked without problems. http://www.modmypi.com/blog/how-to-mount-an-external-hard-drive-on-the-raspberry-pi-raspian I hope this helps.


3

Adding nofail option solved the issue. It turned out it couldn't perform mount because of lack of the device, nofail optiom made it ignore it. This post helped me finding the solution.


3

Typical usage of a Raspberry Pi is that it often gets rebooted. Every Linux filesystem has a mount counter and after X reboots, it will get checked with fsck. Unless you tell Linux not to do that, by way of fstab. fsck is also rather slow on an SD card, and the Raspberry Pi isn't exactly the fastest horse on the race track. If they didn't do this, you would ...


3

Just copy the options that you used on the command line: UUID=12345 /media/USBDrive/ hfsplus force,rw The 0 0 part at the end is optional. You tried with the extra option default which is not a valid option name (there's a defaults, but it isn't useful here).


3

You can repair most such problems on the Pi by rebooting to a root shell. Append init=/bin/sh at the end of cmdline.txt and reboot. After booting you will be at the prompt in a root shell. Your root file system is mounted as readonly now, so remount it as read/write mount -n -o remount,rw / You can then edit files. If you don't get a prompt then ...


3

If you want to edit files on the root partition, an easy way is to download some Linux distribution (Ubuntu for example) flash it to an USB stick and boot from it. Here is a tutorial how to do it. When you successfully booted Ubuntu you can edit your fstab with sudoedit /media/ubuntu/rootfs/etc/fstab If you want to edit it from "Files" hit Ctrl + l and ...


2

Setting it to automount worked for me Append _netdev,x-systemd.automount to your options For example: //192.168.2.11/Videos /home/pi/NASvideos cifs username=NASUSER,password=NASPAS,iocharset=utf8,_netdev,x-systemd.automount 0 0


2

The problem with the RPi not auto-mounting might have to do with the network not yet being up when it runs the /etc/fstab file (as suggested by user KenR). One can resolve this issue by writing a short script that mounts all drives that is run automatically each time the RPi boots: Create script in /etc/init.d: sudo nano /etc/init.d/mountscript Add the ...


2

Try this. sudo mount.cifs //192.168.1.x/ForlderOnMac ./FolderOnPi -o user=XXX,password=xxxx,nounix,sec=ntlmssp Edit From mount.cifs docs user - specifies the username to connect as. password - specifies the CIFS password. nounix - Disable the CIFS Unix Extensions for this mount. This can be useful in order to turn off multiple settings at ...


2

I did several things. It autostarts with the account kiosk cat /home/kiosk/kioskstartup #!/bin/sh xset -dpms xset s off unclutter & matchbox-window-manager -use_cursor no -use_titlebar no & midori -e Fullscreen -a http://127.0.0.1:4079/index.html cat /home/kiosk/.profile # ~/.profile: executed by the command interpreter for login shells. # This file is ...


2

I was able to get this guide to work with Stretch 2017-11-29: https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=161416 A few notes, though: In the second code block, there is no "local-bottom" directory to copy, which is also noted by posts below the original. This is fine, and you don't need an "overlay-bottom" directory for it to work. In ...


2

I feel a little bit foolish. Systemd wasn't the problem, it was the solution! I thought systemd was the default for raspbian. It is not! I followed this tutorial to install it and now everything works fine. It's worth noting that after the change my Pi no longer booted into a console so I ran "sudo update-rc.d -f lightdm remove" to change it back.


2

Your fstab entry is incorrect. It should be something like:- UUID= /mnt/SeagateBackupPlus ntfs rw,noauto,relatime,umask=22,uid=0,gid=0,nls=utf8 0 0 UUID= /mnt/PiData ext4 defaults,noatime,noauto 0 0 Under Stretch you may need to install ntfs-3g to enable writing to NTFS I have added a typical ext4 drive entry. NOTE I ...


2

It's odd that reconnecting the drive won't allow boot to complete. Did you change the drive in any way after unplugging it, and before plugging it back in? If so, that would explain the issue. If this is the case, try to restore the drive configuration as it was before, and try booting again with it plugged in. If you didn't change the drive config, or can't ...


2

The mount I used did not edit the file even though saving worked without any warnings. Mounting via ext2fsd seems to be readonly. Grabbed a Linux DVD, booted my pc into there and fixed it with gedit in root. Correct line to mount is in initial question. Thanks for everyone that stepped me through in the comments!


2

The same error is thrown when you want to issue raspi-config -> Expand Filesystem after resizing the RaspberryPi image physically with qemu-img resize raspbian.img +6G and booting on Qemu. Here is how you can workaround it: Boot your RPi and issue the following command: sed -E 's/mmcblk0p?/sda/' /usr/bin/raspi-config | sudo bash Select (7) Advanced ...


2

This is the line in my /etc/fstab for a Toshiba Canvio 1 TB usb drive. Your UUID and mount points will be different. UUID=A0027BBF027B994C /media/pi/Toshiba ntfs-3g defaults,auto,umask=000,users,rw,nofail 0 0


2

I know you are trying to replace an automount. fstab is confusing, the documentation for mount is somewhat clearer. If you are happy with the way automount works I suggest you let your system automount, then issue the mount command and copy the settings. The following is a line from my fstab. I use noauto and manually mount, but if you want to mount on ...


2

One step you may have overlooked was checking man fstab - in other words, the system manual for creating & maintaining /etc/fstab. Even though it's a bit dated now (Feb 2015), and has at least one error (re behaviour of nofail), it does reflect the software on your system. I've always found the fstab incantations a bit arcane, and man fstab at least does ...


1

For mounting a vfat file system there are particular options. You can set uid=<value> (user id) and gid=<value> (group id) in fstab so it looks like for example: PARTUUID=xxxyyyzzz-01 /mnt/usbstorage vfat defaults,nofail,uid=1000,gid=1000 0 0 Of course you have to use the uid and gid from your user. 1000 is that one from user pi. You can ...


1

I guess you are using Raspbian which comes with systemd. You can try to use automount so the connection is made when it is really used, e.g. when clicking on a link or so. With my NFS shares it works flawlessly. I do not know your settings with WebDAV, so for example I will give you here my entry in fstab for NFS. I think you can adopt it to your needs. ...


1

The nofail option in /etc/fstab will allow the drive to be skipped if it cannot be found despite it being listed with the auto which is one of the values included in the default setting for many file-system types... This answers the OP comment on @RubberStamp 's answer.


1

You should remove the offending line from /etc/fstab and mount your USB stick using udev rules. If you run a GUI, the auto-mount should already be handled by your file manager. If it isn't, or you're running headless, try installing a mount helper, e.g. usbmount. Of course, you can also write a custom udev rule manually.


1

/etc/fstab has a noauto option which will prevent the configured device or partition from being mounted automatically upon boot. $man fstab The fourth field (fs_mntops). This field describes the mount options associated with the filesystem. ... noauto do not mount when "mount -a" is given (e.g., at boot time) Usually, but not ...


1

I forked some existing scripts to easily setup a read-only root filesystem on a fresh install of the raspbian stretch dist. With a single paste of commands from the README, everything will be configured and the Pi will reboot into read-only mode. Two simple .sh scripts are placed in /root. One to reboot in to permanent-write mode (disable read-only mode ...


1

Update: We found that the Mac was automatically adding a directory name to the mount path, //192.168.1.1/volume, so we need to make the equivalent change to the linux mount command and presumably the fstab. ================== Check this out: https://askubuntu.com/questions/427044/mounting-cifs-drive-gives-mount-error22-invalid-argument Particularly the ...


Only top voted, non community-wiki answers of a minimum length are eligible