The Stack Overflow podcast is back! Listen to an interview with our new CEO.
9

Yes, there is a better way. You can edit /boot/config.txt and add this two lines: dtoverlay=pi3-disable-wifi dtoverlay=pi3-disable-bt After reboot, WiFi & Bluetooth will be fully disabled. More info on: https://github.com/raspberrypi/firmware/blob/master/boot/overlays/README


8

Literally the very next thing I tried worked. I spent the last 5 hours working on this so I'll go ahead and share what I did to fix. First, I sourced my drivers from the following github repo. sudo git clone https://github.com/gnab/rtl8812au.git cd rtl8812au modified the Makefile sudo nano Makefile CONFIG_PLATFORM_I386_PC = n CONFIG_PLATFORM_ARM_RPI = ...


5

Credit to pogo-pope on Reddit for the answer: edit /lib/udev/rules.d/75-persistent-net-generator.rules replace: KERNEL!="ath*|msh*|ra*|sta*|ctc*|lcs*|hsi*", \ with: KERNEL!="eth*[0-9]|ath*|wlan*[0-9]|msh*|ra*|sta*|ctc*|lcs*|hsi*", \ Shutdown your Pi, remove the USB dongle you intend to call wlan1. Boot up and plug the wlan1 dongle back ...


5

I know this question asks for instructions on Arch Linux, but since I have been struggling for several days with the exact same issue on Raspbian Wheezy I thought it might be helpful if I shared my solution anyway. Basically, I ended up creating a solution where my Raspberry Pi (RPi) tries to connect to one of its known wireless networks, and if that do not ...


5

Problem solved!!! I will explain here the steps I took: I bought a good 2A charger, which at the beginning helped to see the blue light of the dongle. However it didn't yet connect. So googling and googling I came across this page https://amalgjose.wordpress.com/tag/raspbian/ he gives a solution so that the dongle gets detected always. If you do exactly ...


4

You can install any VNC server app on your Android, such as VMLite VNC Server. On the RPi you can use a VNC viewer, such as SSVNC (sudo apt-get install ssvnc) or xtightvncviewer (sudo apt-get install xtightvncviewer) to connect to your Android VNC server and take control of your Android desktop. This does require you to have access to the RPi - so it doesn't ...


3

You don't have to change to dhcp. cat /etc/resolve.conf should show you which dns servers are currently configured. As dastaan said, you can just type ping google.com to see if you are resolving basic addresses. You can also use nslookup google.com To add a dns server w/o changing your permanent setup, just add the entries to /etc/resolv.conf. This ...


3

Usually via DHCP you get also the names of the DNS servers to use so that you Debian/Raspbian can automatically configure them in order to resolve hostnames into IP addresses (and vice versa). When you go static you need to specify it. On recent Debian/Ubuntu, this is done like follow, and I believe that this would be similar on Raspbian. Add an extra line ...


3

I suggest using Bluetooth Low Energy (BLE). You can get a dongle (pay attention that it is a BLE and not regular Bluetooth dongle). As name already says - it is low energy. Then I would setup an ad hoc network over Bluetooth connection. I have written a blog post about that. You can use ssh with IP address set up by DHCP.


3

Per the comments below your question, that's just not how USB works. Your desktop is enjoying a variety of advantages over the Pi - a USB 3.0 adapter, superior bandwidth on its internal buses, faster CPU, etc. etc. etc. It's not entirely realistic to expect similar performance from a Pi. The Netgear adapter you've spec'd may well not work as expected in ...


2

Wireless keyboards could operate by using radio frequency (RF) or infrared (IR). RF techniques range from 27 MHz to up to 2.4 GHz (according to wikipedia). With Bluetooth being a widely used technology. While both WiFi and Bluetooth share the 2.4 GHz band they differ both in technical aspects as well as in their objective. So in short: Your (presumed) ...


2

The easiest way (in my opinion) is to use the create_ap script as linked in: https://wiki.archlinux.org/index.php/Software_Access_Point


2

it shows me a bunch of wi fi networks...so it must be working right? Yep, you would not be able to scan for wifi networks without a working wifi adapter. Try: service networking stop dhclient -r wpa_supplicant -B -c /etc/wpa_supplicant/wpa_supplicant.conf -i wlan0 dhclient -v wlan0 Wait ~5 seconds between the last two commands; you'll see a bit of ...


2

I second the power comment. I too have had "working" Pi configurations that suddenly started showing problems after months. In my case I was running edimax wifi and shairport for apple airplay support. The bandwidth was always marginal, but it worked. One day the wifi died, and I ultimately determined that a better wall wart solved the problem and ...


2

If an adapter doesn't show up in lsusb that usually means that it needs firmware file(s) and your dmesg output proves that: [ 140.213122] r8188eu 1-1.2:1.0: Direct firmware load for rtlwifi/rtl8188eufw.bin failed with error -2 [ 140.213169] r8188eu 1-1.2:1.0: Firmware rtlwifi/rtl8188eufw.bin not available Installing the firmware-realtek package should ...


2

You will need to allocate the extra resource for a server software to send these details to your chosen solution. It is unclear what you want to be sending over, just text data? Or image data too? For Images, video streams, you can use a normal WiFi dongle, during debug mode plug it in and start your server. A simple Python web server that can push the data ...


2

If you are using a low power source like laptop USB port or external battery try to connect it to electricity using a 5V charger. Try the following: I do a static config for eth0 bcz its easier for me to get the IP address but u also have to configure your wired device into the same subnet $ nano /etc/network/interfaces auto lo iface lo inet loopback ...


2

Most Realtek Wi-Fi dongles do work on the pi, i had the same problem with a different Realtek dongle when i first tried to use it. You should start by getting an internet connection with a network cable and making sure it is up to date by using the commands : sudo apt-get update Once that has run you run: sudo apt-get upgrade After a reboot then you ...


2

If you configure the WiFi connection via /etc/wpa_supplicant/wpa_supplicant.conf, it should automatically connect - example file contents: ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 network={ #Set wifi network name and password here ssid="NAME" psk="PASSWORD" # Protocol type can be: RSN (for WP2) and WPA (for WPA1) #proto=WPA2 ...


2

If you are sure your adapter works fine, try running the command sudo ifconfig wlan0 up When you do this, all the available wifi networks should show up when you click the wifi signal button at the top right of the screen. You should then be able to click any of them and type in your password. Edit: Try running the command sudo iw dev wlan0 scan since you ...


2

Assuming you don't have any network equipment other that the WIFI dongle that you could unplug, you could simply write SUBSYSTEM=="net", ACTION=="remove", RUN+="/path/to/command" into a file named /etc/udev/rules.d/my_custom.rules. Note that you need to specify the full path to your command, since it will be executed directly, without using a shell.


2

To build this module from source, I did the following on my RPI2. Install build tools: # apt install build-essential bc git wget Get kernel source code # cd /usr/src # git clone --depth 1 https://github.com/raspberrypi/linux.git # ln -s linux $(uname -r) # ln -s /usr/src/linux /lib/modules/$(uname -r)/build Prepare linux build headers # cd linux # wget ...


2

I've found that most of my chargers don't provide enough power to my PI3, even if the "under-voltage" icon doesn't show up. This causes the Wifi and Bluetooth to be disabled in an otherwise working system. An original Apple iPad charger did the trick.


2

I suppose you have completely setup and running Building a 'Packet squirrel" using Raspberry Pi you have linked in your question. It is using systemd-networkd. If you want to extend it with WiFi you also have to use systemd-networkd, in particular to use *.network configuration files. So try this and add setup wpa_supplicant in addition to the existing ...


1

Before continuing with this answer, type the command lsusb and make sure the adapter is listed. Sometimes the RPi does not recognize Wi-fi adapters in the GUI, but this doesn't mean you cannot use them. You will just have to edit system files manually instead. So, first edit your wpa_supplicant file be entering the command sudo nano /etc/wpa_supplicant/...


1

You don't need auto and allow-hotplug, just allow-hotplug. This also starts at boot automatically. Adding auto as well used to sometimes cause a delay at boot when the network connection was not made. 'auto' is more for servers where the boot can be configured to wait until the network is established, 'allow-hotplug' for desktop / laptop type users. I'm a ...


1

In desperation I tried adding a new network, which it still assigned to wlan1, but this now works. It seems that Ubuntu needs connection for each Adapter/Network combination. I now have 4! (2 networks * 2 adaptors). I have since updated to Ubuntu 16.04 and run on my 2 Pi3. I again had some slight difficulties with networking. I have at least found where ...


1

Make sure to boot the Pi with the usb dongle attached. Edit /etc/network/interfaces and add the following to the bottom: iface wlan0 inet dhcp wpa-ssid "your network name" wpa-psk "your password" If you want to give it a static ip then just do: iface wlan0 inet static address 192.168.0.XX #static ip address ...


1

I had a TP-LINK 723N, which is basically the same thing as the 725N V2. Raspbian did not support it out of the box. I had to download and install drivers; specifically the 8188eu.ko. I used this forum post to get mine working.


Only top voted, non community-wiki answers of a minimum length are eligible